Hair Groom Asset clipping through head and shoulders

I am setting up hair for a modular character and I’ve got it imported properly into UE4 (at least I think so) but when I add it to my character (with or without a binding asset) and turn on physics, the hair clips through the head and shoulders of my character.

My first thought was that the Physics Asset did not cover the head properly, but it seems any changes I make to the PA do not really do anything to how the groom asset is situated on my character’s head.

I did some more research and found another user with the same issue who solved it in blueprints:

I have tried to use the same blueprint code but I am not sure how to set up the “In Binding” and “Asset” connectors since he did not include that in his screenshot:

Can anyone help me with how to set up those particular parts of the blueprint properly? Also, shouldn’t the Physics Asset do something here? My modular character is split up into Torso, Legs, Feet, Hands, and Face – should I have a unique Physics Asset for each modular part or just one for the entire character?

1 Like


I am currently working on a character in UE4 2.26.2 and having a similar challenge of hair groom clipping through character mesh.

Would really appreciate it if anyone can help resolve this.


Just could not let it go, So I did further digging and came across this Simple procedure in UE Docs, what we are missing is the first step in the link below.

Enable Support Compute Skin Cache .

I did that and went on to restart. Reimported my hair and made another binding asset. Followed through with it in my Blueprint and it worked.

I hope it works for anyone having similar challenge.

NB: My current UE version is 4.26.2