Groom strand based hair missing after game packaged for Linux(Ubuntu 18.04)


My team is looking to make some character with strand based hair. The hair renders fine in UE4 editor. However after the game is packaged for Linux(Ubuntu 18.04), the hair simply disappears.

We tried both cross-compiling from Windows and direct export on Linux, the problem remains the same.

To replicate this, we found some random strand based hair from MetaHuman and bound it to the head of human character from the third person template. And we saw the same issue…

We tried to debug the packaged game, but the console did not show much information about hair.

Any idea what could have gone wrong?

For your reference, I can see the hair when I play in Standalone Game as well.

We have same problem. Groom component in Linux builds (Debug/Develop/Shipping) doesn’t work at all, but in UEditor and in Standalone Game launched from UEditor hair (Groom) works good.
UE v4.27.2
Linux KUbuntu 18.04 x64, NVidia GTX 1070 (driver ver 495).
Plz need help!

Screenshot_20211221_151510_clmp Screenshot_20211221_152532_clmp

The issue was reported and traced by Unreal Engine Issues and Bug Tracker (UE-136646). Maybe we can get more people to vote on it so that it would be resolved earlier?

I have a solution. Edit your DataDrivenPlatformInfo.ini in Engine/Config/Linux
and copy [ShaderPlatform VULKAN_SM5] part form Engine/Config/Windows

I think it happens at line 656 of RHIDefinitions.h. and bSupportsHairStrandGeometry is 0

Thanks for solution, but it not works for me…
I added in file Engine/Config/Linux/DataDrivenPlatformInfo.ini lines from Engine/Config/Windows/DataDrivenPlatformInfo.ini.

First test: development and release build - no hairs.

Second test: with additional line “bSupportsHairStrandGeometry=true”, no hairs in release build.
Development build crashes at line 239:

In Unreal Engine v5.0.1 hair works good in Linux builds.