Green Bug pattern on texture

I can find green bug patterns on various places of my texture.
How can I fix this please?

Hey TAP, can you show us the material setup?
I think one of your values needs clamping. But I cant tell you which one.

Hey , Thanks for helping me out!
This is the material setup. I do not really know what I’m doing as I’m new to Unreal Engine. I tried to follow this link to create displacement maps but it didn’t work so I made the displacement in blender and imported into UE.

[link text][1]

Dont worry TAP, we where all beginners at one time :slight_smile:

Allright, your metallic value should be “1” and not 100.
0 means no metallic, 1 means metallic.

One-minus your specular texture, and multiply it with a 0-1 value and put it in your roughness input instead of specular.
UE4 is a physically based renderer, so specular isnt as important, while roughness is the most important.

Keep in mind that 0 = off, 1 = on, and 0.5 is 50% gray.

If you use your roughness well, you might not even need the metal input :slight_smile:

Is this right? And sorry, what do you mean by one-minus the specular texture?

I think the green bug is still there,

there is a node called one-minus (hold down the O-key and left-mouse-click)
which inverts values.

I personally think that you dont need the metal option, and your roughness value’s need to be more soft, less black.

I also think the texture itself has some blue values.

also, make sure your specular/roughness/AO textures have SRGB turned off.

Oh, thank you very much! turning the SRGB off did the trick!!!
I’m just curious, can you tell me what one-minus does?
I think I needed to put the one-minus to get rid of the green bugs as well.