Download

Grass not receiving shadows properly?

Hello there, I have an issue with grass lighting and could use some help. I have already figured issue is not in foliage planting tool as it still persists when hand-placing the meshes around. I have tried tweaking the material but cant figure how to improve this, here a screenshot of the issue:
GrassShot2.jpg
Grass does receive shadow but brightness differs a lot from other surfaces, I want them to be same brightness as the ground below

And here the grass material:


This is not a self-made material, it came with asset pack and Ive been trying to make it work better with my lighting setup but something is not working
Any tips greatly appreciated! Im not much of a an expert with materials…

Tried tinkering with shading model but does not seem to help :(, grass looks different (darker) with default lit but is still not affected by shadows properly

Try reducing the SubSurface value (multiplied by the colors/gradient lerp). A value higher than 1 is boosting the color to brighter output. So 0.8 or somewhat lower might work.

Tried tweaking subsurface, it does change color but the changes seem to be global and does not only affect brightness in shadow. Lowering the value makes grass darker in shadow but also in lit areas

Not sure. The other potential fix is using post process volumes over the shadowed areas, but it’d require creating an exact shaped mesh for each one to avoid darkening spots of grass outside the shadow.

The material should have checkboxes if it is allowed to accept shadows or not.
my gues sis that this setting is not properly enabled.

You can try it by replacing the mateiral on the grass with a custom material instance in which you only use white.

If you take a screenshot and the white on the lit side is as bright as the white on the right side, then the shadow is not being allowed.
this should Not be the default behavior, so you will have to specifically find the box to uncheck to visualize it.

however if you arent happy with how dark the test material turns, you need to tone down your skylight settings.

As you can see it is now fixed! I couldnt really figure out what was causing it to not light properly and ended up reworking the material by using another foliage asset as a reference. Now as to how exactly I changed the material, well, Im not going to tell because thats a trade secr… just kiddin’ :rolleyes: Here is the new material setup:

Blend mode is now masked, shading model subsurface, new opacity parameter (low values work well) and the blueprint looks like this

Thanks for all the replies and thankfully this issue is now resolved!

Funny, I almost suggested using subsurface shading model. Thanks for the info of how it was resolved.

subsurface values are still needed otherwise you won’t get translucency when the sun is behind the leaves like for real grass.

2020-05-14 16_46_53-fetch (1401×924).png
Sambhaid, You mean 0,0,1,0, don’t You? :stuck_out_tongue: