Download

Grass Looks Very Pixelated/Distorted/Noisey

Whether I load one of the maps in the Kite Demo or follow along with any number of tutorials… I can’t get sharp, clear grass in my maps. In general, rocks, textures and trees are completely sharp but grass just falls apart. I am using a GTX 760… Is this my main limitation or are there some settings that I overlooked that can fix this? I attached an image that demonstrates my problem (followed a tutorial directly from the UE 4 Documentation) and I think it actually looks even worse than this in motion.

4485b96f4de4156821997bb12d47c3231af4f12d.jpeg

Thanks in advance!

looks a bit as if your opacity mask’s resolution is too low and as a result you get those apparent pixelated edges.
opacity masked knows only visible or transparent so for transitions that look smooth in photoshop you may not get the desired results. apply a threshold adjustment layer on top of your layerstack to see how the mask will probably look like with masked blend mode. you can adjust the threshold value and see if you like any particular point the most and then get the same result by tweaking the opacity mask clip value in your material.
for “smoother” edges you will have to increase the resolution though.

I would suggest to use geometry plants in close distance.
Especially if you planning to use any VR devices in future.

Thanks guys for your responses. I’ll try tweaking the opacity mask clip value as soon as I get a chance. This is my third day using Unreal so please bear with my potentially stupid questions but what’s odd to me is that even when I open up either of the maps from the Open World Demo collection, the grass looks really bad like mine (even though the rest of the maps look incredible) but when I watch videos on YouTube (even at 720p), the assets look awesome. The grass asset in the image I attached above is directly from the Open World Demo collection too. Is this because the good looking videos are captured at 1440p or 4k and scaled down or am I missing something here?

Here’s an image of some grass I found from another post in these forums and even though the image is smaller, the resolution looks much better than what I posted above:

3c07572408054c6470a7e527db775c4f196d8469.jpeg

Also make sure
-that you use the “epic” quality settings
-it could also be that this is caused by the texture streaming -> what happens when you set the mode to “never stream” (in the texture settings)
-probably the wind effect makes it blurry -> disable it in the material and check it again :slight_smile:

Thanks for your response. Ok, so I checked that everything is set to epic, tried setting the texture mode to never stream and turned off the wind and still it looks very bad (I turned texture streaming back on). I attached a screenshot in the editor - it’s definitely not supposed to look like this. I notice if I turn resolution scale all the way down, there is no difference in quality so I think it’s definitely a resolution issue. Again, this is the super high quality field grass asset from the Open World Demo. Any ideas? Could it be a NVidia setting? Thanks in advance!

Grass-Example-2.jpg

Ok, I figured out the issue… Anti Aliasing + Dense Grass + Wind Effects is the problem. Is there a way to get very specific about AA in Unreal? For example, set AA to high for the world but for certain materials/meshes turn it down?

For anyone else who is experiencing the same issues… I left my AA settings as temporal in my post process volume, set upscaling to 200 and set my AA quality down to medium and I’m very pleased with the results in game. My FPS is pretty low but still acceptable. Here are some images with just some basic foliage:

Better-Grass-1.jpg

Better-Grass-2.jpg

Yes, Temporal AA is the problem on the grass. The reason why screenshots often look good is that they are taken with the “HighResShot” command, so if you type “HighResShot 3” then you will get a screenshot with 3 times your regular resolution and then the temporal AA blurring is not visible. Enabling downscaling from 200% is very expensive.