Download

Graphic quality of a packaged VR project gets lower

Hello everyone!
A few days ago our team finished a HTC VIVE demo in architecture visiting. We are pleased with the results of VR preview mode. However, when we run the packaged one we find that the graphic quality is not as good as we experienced in the VR preview mode.
I’ve searched the forum attempting to get a solution. I’ve tried adding command’r.ScreenPercentage300’ in the level BP; Adjust the BasicGameXXX file; But all in vain.
Hope someone has encountered the same issue before can help me! Huge Thank you!

There should be a space in between screen percentage and 300 like “r.screenPercentage 300” you can check if it worked by hitting the ~ key in the VR Preview and it will say the command wasn’t recognized if it was input wrong, also on a side note 300 is really high I would settle for 150-200

is it a texture streaming issue? Meaning are the textures what is not of quality, or is it the shadows? or is it appear to be a lower resolution? Could it be the AA?

oops… That’s embarrassing… Command ‘r.screenPerentage xxx’ do affect the quality. However when I run my packaged project its quality is still low. I tried to add the command 'r.screenPerentage 150’in it and it works. I have to type ‘stereo off’ to first and then type ‘r.screenPerentage 150’. If I type ‘r.screenPerentage 150’ in the VR mode the command won’t work. Is there a way to customize a package project’s screen percentage at first place so that I do not have to add the command line later?
By the way, thanks for your VR tutorial , I learnt my teleportation mechanism there! Your awesome!

Hi Dave!Thank you for your reply. I think Mitch have solved my problem.It is the command line ‘r.screenPerentage XXX’.

Ive been having this same problem. The end result when I package the product seem blurry or lower resolution. Even if I start a brand new project from scratch, it still does it. 4.11 works fine though and look much better. It’s just 4.12 that I have the problem with.

Their are a couple of common causes for this, one of them is that the VR Preview is in fact higher resolution then the default package settings, the reason for this is on the Vive the render resolution is controller by the screen percentage parameter (On the Rift it is controlled by the HMD SP parameter which is seperate) in a packaged game the screen percentage will default to 100 (which means the engine will render your frame at the native resolution of the display).

For VR however we do not want to render at the native resolution of the display for various reasons but the main one is that when we correct for the lens distortion we will lose resolution in the process.

Therefore to actually get a picture that is at the resolution of the display you will need to render at around a 130 screen percentage (that is 130% of the screens actual resolution).

To do this you can change your default engine.ini in the packaged game (a good starting point can be found here) or either call the console command ‘r.screenPercentage xxx’ on the level begin play (where xxx is the SP number i.e. 130)

Another common issue of perceived lower resolution is the fact that when the editor is open all the levels materials have been fully loaded in the background while you work so when you hit the VR preview button the textures have already been loaded.

To fix this in a game build I believe you just have to wait until the textures have fully loaded (not sure the actual solution to that one but if anyone has a suggestion I would love to hear it)

Tried both and it doesn’t seem to help.

Hey guys, I found out that the command r.setres affects the visual quality of the build, which is weird because I thought it would only affect the monitor but apparently it recognizes the vive as a screen as well.
I just added on the level blueprint a r.setres command with a high resolution (I used 1920x1080 because it’s my monitor res) after the enable HMD node and it improves the visual quality. If you type the command you’ll see the default res is pretty low.