Download

Grain on high detailed textures

Hello, I have big problems with high detailed textures like fabric. On the screenshot below you can see grain and noise. I do ArchVis, that’s why high detailed textures are so impotant to me.
I can’t find same issue on the forum or in the Answerhub for 2 hours, if you have a link please give it to me.)
How to fix it? Thanks!


Very high frequency, contrasted textures will often show moire curves or unwanted noise like this in any render solution - the detail is sub-pixel, and doesn’t resolve very well.

Things you do to try to solve the issue (most apply to any renderer):

-render at double or 3x resolution, and downsample using a pixel filter of your choice. My favourite is Lanczos4.
-use a lower-res texture (you aren’t resolving the detail that’s there anyway)
-slightly blur or de-contrast the texture you are using
-increase your AA samples: in a console window (or press the tilde key at the top left of your keyboard) type:
r.TemporalAASamples 64
(the default is 8, 64 is overkill)

Hope that helps - for a very fine, contrasty texture you may need to use all of the above.

I would also try playing with the mip generation settings on your texture properties. Sometimes it may help to use one of the Blur options of varying strength.

Thanks a lot for your answers!

I tested some options. Solution has founded and I write it here. =)
At the first I try to use a lower texture, I blur it a little, it helps, but grain was still (less) and quality was lost too.
Unfortunately, I have not found information about a pixel-filter (Lanczos4), i’ll grateful for this link.

Then I used mip generation settings on texture properties. I learned what mip it is, but my texture hadn’t generated mips. Then on one of the forums I read that it’s possible to use function «Power of two mode => Pad to Power of two» to create mips. My texture was 1000х1000 and after I applied it, grain disappeared, but to my texture was added thin black bars to size 1024х1024. I updated my texture as a result black bars disappeared too.
So. All textures must have resolution equal any power of two, only in this case mips will be generate automatically. At the link below you can find a table with the possible size of the texture.
http://www.vlsm-calc.net/powersof2.php?lang=ru

Good deal. Often times it is easy to overlook the simple things when trying to diagnose a problem so I am glad you found the issue!