Grain Intensity disabled but still visible

You will notice if you are careful (especially in dark areas) that there is a permanent grain effect active even if you disable Grain Intensity or set it to 0, is it normal ? it does this on every scene, even home made ones.

It’s not ‘that’ noticable but still, you can see it. And I hate that !

If you have too much trouble to see it, in the editor, put the camera in a very low lit place in front of a texture, then go in ‘realtime’ mode, then hold left mouse button in a part of the UI to pause the realtime rendering (for example in the blank part just at the right of the ‘Launch’ button) and look carefully, when you will release the left mouse button, the scene will have some grain, and when you hold it again, the grain effect will still be present but freezed.

I’m very courious to know what is the cause of this, I suspect Grain Intensity to be the cause because when i increase the value, the grain effect is exactly the same but much more visible, would be great if it’s totally disabled when Grain Intensity is set to 0 or disabled.

Let me know about it and thank you for your time :slight_smile:

Edit : it is visible in editor and in standalone mode :slight_smile:

Hey Deu,

I’ve attempted to reproduce this issue but I don’t see what you described. To reproduce, I did the following:

  1. Open Content Examples project, open Lighting map
  2. Drop a Post Process Volume into the level
  3. In Details, enable Unbound for the volume
  4. In Scene Color, set Grain Intensity from 0 to 1
  5. Note grain effect
  6. Disable Grain Intensity

At that point, the Grain effect disappeared for me. If you follow the same process in a new project (or the level I tried), do you still see the grain? Is it possible you have multiple sources of Grain Intensity (such as on your camera itself, or multiple post process volumes)? If you go to Show > Post Processing (in the Viewport) and disable Grain, do you still see some grain effect in your level?

Ben Halliday

This is what i made :

-new blank project
-remove everything from the scene
-drag and drop a cube brush
-drag and drop a point light and make it intensity 500 only so its quite dark
-drag and drop a post process volume and set it to ‘unbound’

the grain is visible, it is hardly noticable but it is here i can see it.
I made a screenshot (doesnt show much more than what i said but…) :

if you want to see it, put the grain intensity to 1 and realtime in the editor, then do the hold left mouse button trick I explained, you will see the grain freezed, and as soon as you release the left mouse button, it will start again, then do it with intensity 0.5, then 0.2, then 0, and you will still see this freeze/start again grain effect at 0 if you look carefully.

This is not a troll I promise !

Edit : by the way, I just noticed you can clearly see it in the screenshot !! especially in the bottom part of the 3D image, you have to look closely, but its definitely there.

Hey Deu,

I followed your steps and don’t see any grain left at 0.0. I also don’t see any in your screenshot, but that’s so dark that I can only barely make out that there’s anything there at all.

We think it might be possible this is a result of your monitor settings or monitor quality. One last thing to check: if you go to Show > Post Processing (in the Viewport) and disable Grain, do you still see the grain effect?

Yes yes, it’s not my screen since it feezes when i do the left mouse button trick. I will launch Unreal 1 to see if it is really not my screen (since the game has a real dynamic light system).

Edit : here are some screenshots (in PNG format, so no quality loss or anything) :

Edit 2 : YES ! OFC ! use the windows magnifier at 1600%, you WONT be able not to see it ! can’t believe I didn’t though of it earlier !

If you go to Show > Post Processing (in the Viewport) and disable Grain, do you still see the grain effect?

Yes I do, no differences (didnt know about thoose options ! ^^)

Ok. Found it. It’s the tonemapper. With tonemapper disabled the dirty pixels are still there, but not moving.

Interesting facts : with tonemapper disabled (colors are looking 24 bpp like ^^) when I increase or decrease grain intensity, it doesnt change anything, the thing I’m tracking so hard is definitely linked to the tonemapper.

Looks like tonemapper with grain intensity 0 has a dim grain effect, and increasing grain intensity just makes it stronger.

Don’t hesitate to do the windows magnifier 1600% trick, it makes it really easy to see. observe difference on image stability with and without the tonemapper, with you will notice a dim grain effect, without, none.

Any pogress ? ^-^

Hey Deu,

Sorry for the delay, I’ve been out sick. Cool that you were able to narrow it down!

I’m taking a look into tonemapper now. Are you referring to the Color Grading option in your post process volume? I’d like as many details as possible about how you have your tonemapping set, please. Could you also provide the texture you’re using as your LUT? Thanks!

I was writting a loooong message but my computer crashed -_- while I was launching UE4.0.2 btw ^^

I recently formated my SSD and reinstalled everything (not for this ^^), noticed same effect. I took the time to mess around with all possible options and only disabling the tonemapper stopped the grain effect.

my colorgrading is of course disabled/set to 0 and none.

The texture used is the placeholder basic texture used when you drag and drop a box.

Hey Deu,

I am so sorry, I never saw this reply! I’m going to pick this back up and find a solution for you if it is still occurring. Are you still seeing this in the latest update? If you can check on 4.2 and let me know, I’ll help you get this sorted out. I just followed the steps you provided in an earlier post, and I am still not seeing a grain problem in 4.2. Thanks, and sorry again!

Ben Halliday

No problem :slight_smile: you must be very busy I’m glad you answered, even late :slight_smile:

For the moment, I don’t have the 4.2 engine update (I guess it will be aviable soon) but as soon as it is aviable in the launcher, I’ll test it. I keep you informed :slight_smile: I never uploaded a youtube video but if it is necessary, I’ll do it.

4.2 is available now! You should see the option in your Launcher’s version drop down menu, right above the Launch button.

Thank you I didn’t knew you could update that way !

Just did it and sorry, but it is still visible, do you want me do make a youtube video to show it properly ? I will not do it in less than a week because I am very busy right now, but maybe in a week or 2.

I also noticed that reflections have changed, they look better now, perfectly ‘stable’ and sweet with temporal AA, but with FXAA or no AA, they look like they were a shader bug. Still latest nvidia drivers and everything.

A video might be nice, so I can see exactly what you’re seeing, but I will continue investigating without it and hopefully get a reproduction before you need to take that step. Thanks!

No, focus on something else, they are greater problems than this one, I appreciate :slight_smile: but they are greater problems, I’ll make a niiice video showing it ! You focus on greater problems while I focus on miscallenous stuff ! haha ! I want to be a (more or less) active part of the community to improve the engine, I’ll be glad to help my way :stuck_out_tongue: I keep you informed as soon as the video is uploaded :slight_smile:

Sorry to answer now, since it is a very late reply and the subject is marked as resolved, I had to lend my computer to a friend that needed it way more than me during the past few month, still I had the time to investigate the problem few times more, I cant tell exactly the version, maybe 4.3 or 4.4, but the problem is not here anymore, now 0 grain really feels grain disabled, good job to your tech team ! And you too for checking this and your perseverance, since it was a very ghosty like problem and could have easily be misunderstood as a troll !