GPU Profiling for ArchViz

Hello Dear community members!

I’m a total newb using UE4 merely for 3 weeks now, I am trying to develop an ArchViz scene although I’ve been running into some performance issues almost from the very beginning.

My scene is extremely basic only piano being something slightly more complex as a geometry the rest is extremely basic geometry yet t​he GPU usage is pretty high in the Standalone packaging, it’s almost 100%.

Here’s my PC setup to give an idea;

i7 8750h
GTX 1060 6gb
32GB Ram
SSD Storage

The scene has 60FPS capped by something which I couldn’t find (but that’s the topic for another subject), it’s extremly stable at 60FPS 16.67ms in the engine, but as soon as I hit play GPU usage spikes to 80%+ although FPS and ms are still perfectly stable, it somewhat drains my GPU.

I tried to follow through like 10+ GPU profiling/optimization tutorials and so far it seems like I have a rather optimized scene.

Some SS’s from the scene

And the standalone with the task manager.

Thanks to everyone in advance who would take time to help this newcomer and if there’s a similar topic please redirect me and delete this one.

Yours virtually,

Hi Zboynk,

To unlock the FPS, have you tried all the steps described here?…real-engine-4/

Ciao ,

Thank you for your response.

I tried everything;

Disabling VSync under Nvidia Control Panel
Turning off BatteryBoost under Nvidia Experience
Smooth Frame Rate off under Engine settings
r.Vsync 0 (console)
t.MaxFPS from 0 to 200 (console)

However it goes below 60 with console commands or even SmoothFrameRate but never above, it seems like it’s hardwired to cap at 60.

And nevertheless it’s taxing the GPU to it’s fullest which is the main problem.