GPU Particles render in editor, only a few render when playing

I have a load of GPU particles in UE4 for stars. They render fine in-editor, but as soon as I hit play or simulate they all disappear except for maybe 4 or 5 out of hundreds and hundreds. I’ll attach before-after images to show what I mean below.

Using normal particles would be fine too, but they completely disappear when playing! Other particles in the scene are unaffected.

Thanks in advance. :slight_smile:

Hello Anja,

Have you set the bounds for the gpu particles?
Not doing so is the main reason they wont appear.
Also, keep in mind you will need to restart ue4 after setting it, else it wont have any effect.

Hey Luos,

I didn’t realise you needed to restart after changing bounds, however this has not rectified the problem. 99% of the stars still disappear in-game. :frowning:

Thanks for your suggestion.

Ok, another thing you can try…
Are you sure the particles dont have any LOD’s?

that might be the culprit.

How do I go about doing that please?

hopefully this video helps: - YouTube

Wow thanks so so much for that Luos! That wasn’t the problem unfortunately, and in a fit of rage I deleted the particle and redid it since it was so simple anyway. It now seems to be ok. So, who knows what the problem was… I guess I must have knocked a button or something?

Thanks for going above and beyond with your response though. So good of you.