GPU Particles randomly stop spawning (stutter?)

  • Tested on multiple rigs, with multiple high end setups. (think: 1080’s, 4ghz i7 cpu’s 32gb+ ram, m.2 ssd’s etc)
  • Bounds are fine, though tested with less than -10k-/10k, 100k/+100k up to -100m/+100m bound sizes.
  • fps barely dips under 120fps, nice steady 8.33 ms.
  • max amount of cpu particles in view: 350
  • Max amount of gpu particles in view: 45.000
  • Happens in viewport, PIE, Standalone, simulate.
  • tested with and without global vecfields.
  • No LOD’s present that could be hindering.

image with stat gpu particles, particles, particlememory:

GPU particles randomly stop spawning for miliseconds.
I know the “hardcoded” limit is around 1m particles, but im not even getting close to 1/10th of that.
Highest calculated count is 45k gpu particles visible at any given time.

Unlisted YT video showcasing problem:

And now comes the best sentence in gamedev world: It was working fine before.

I cannot edit ini files, tweak editor settings and the like, as it needs to run fine as a marketplace package.

Any idea whats going on?
It happens mostly with the “trails” but like I said, the bounds are fine, spawnrate looks good, required looks good, etc. and by now I think I can safely say that I dont miss the obvious things. (then again, who knows hehe)
additional images:

Hmz have you tried to Bump/Decrease the particle amount? Does it get noticable worse or better? (Excluding the possibility of a reached Limit / Optimisation Point of some Sort)

Also try to make a Copy of your Particle and delete 2 out of the 3 Emitters you got. Is it still stuttering? (Excluding the possibility of Stacking Settings between Modules)

While at it make 2-3 Copys of what you already have placed in the Scene. See if all of them Start to Stutter at the same time. (Not sure what Im going for in that case but somewhat related to Cache or global things?)

Trying to find the Relation to whats happening. Might give you enough info to Sort it out if you can figure out at what point it starts to happen.

Aside from that I can tell you that small spikes won´t be noticable on the FPS / ms Counter or even the Live Stats. Those little Buggers you will only See in the Profiler :stuck_out_tongue_winking_eye:

I don´t think thats the Problem, would be more Obvious to See with the Eye. But I guess it won´t Hurt to give it a Run. Every bit of Info you can Spot helps.

yes, went from a few 100 particles to more than 100k, both had the issue, though obviously with only a few particles active you wont notice it as much as with 100k particles.

I disabled any limiters in cascade.

disabling/deleting parts does not help (unless I delete the gpu particle)
Again, this happens with ALL the emitters, the trail is just most obvious. but basically any “explosion” you see in that video should result in more particles. it randomly doesnt.

Currently the blueprint doesnt allow for copies.
What I did notice though if I dont use any blueprints it seems to work fine?

But Celeste doesnt notice anything odd in the blueprints that could/should cause this.

edit: need smore testing, but apparently there where three more (identical) blueprints in the scene that constantly told emitters to enable/disable.


Solved for now, no exact reason why the blueprints where messing up but it works now.

The “stutter” does reappear after 700k gpu particles are all at it at the same time.

thanks for Nacht for pushing me into the right direction :slight_smile: