GPU Particles not obeying InitialSize parameter

If I create a GPU particle system, and set the “Initial size” module to be a “Distribution Vector Particle Parameter”, it seems that the only value ever obeyed is the “constant” value (essentially the default value) of that parameter. Changing the parameter’s value (either in a blueprint, or modifying an emitter’s Instance Parameters) results in no change at all.

Deleting the GPU Type data module (switching it back to CPU particle) makes the InitialSize parameter start functioning correctly again.

This is contradictory to the answer provided in this forum thread, which clearly shows the exact same approach being used on a GPU particle system.

This is in UE version 4.8. Please advise.


Hi there,

An oddity of GPU sprites is that they require a “MaxSize” value which they take from the distribution. This can result in some seemingly odd behavior.
If you set the Constant.x of your parameter distribution to >= to your max desired value then this should work fine.

Let me know if you have any problems.




We think this post contains useful information which we would like to share with our public UE4 community. With your approval, we would like to make a copy of this post on the public AnswerHub which includes the discussion but strips out your username and company name. Please let us know if you are okay with this.


Sure enough, that did the trick. Thanks for the tip!

Fine by me, go for it! Thanks.