GPU Particles Not Colliding/Acting Weird in Preview View

Hi guys. I’m unable to post screenshots, so I’ll describe what issue I am having in detail

Basically, I have rain and I want it to collide with objects such as the overhead rocks even if I am not looking at the object. I want a lot of particles so I want to use GPU sprites.
However, when I switch to Distance Field collision the preview glitches out and I will just get flashes of all the different particles rather than the rain falling properly. Switching back to Scene Depth fixes the preview.

Additionally, despite having Generate Mesh Distance Fields in the project settings and having restarted the project the particles refuse to collide with anything except the Landscape

This feels like a bug (especially the preview issue) so if anybody has any ideas on how to work around this it would be great

Thanks :slight_smile:

Side note: Removing the GPU sprites module to convert it back to CPU breaks the particle system entirely


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.