GPU Particle collision works in editor but not in game


GPU Particle collision has stopped working in my main project when playing the game. Particle Collision works fine (both Scene Depth and Distance Field) in the editor, but when using PIE or a Standalone Game, neither collision type works and the particles pass through all objects.

If I make a new 4.15.2 project, GPU collision works in editor and in game. GPU Particle systems which work fine in game in new projects (e.g. the Content Examples GPU Particle system) don’t collide in game when migrated into my main project, as shown below:

All scalability settings are on Epic. Things were working OK until very recently and there are no asset changes I can see which would account for this problem. Are there any PIE or Play-specific scalability or particle settings which may have been altered? Or any other project settings which might account for this problem?

Grateful for any suggestions.

I did find the following people having similar issues but none of the suggested fixes worked for me:

OK I have discovered the reason - I have a Scene Capture Component 2D attached to my character for an inventory viewer, and this is disabling GPU particle collision as described below:

I shall vote and hope for it to be fixed…

If anyone is interested in how to workaround this problem:

I have an inventory system with a HUD widget that renders output from a Scene Capture Component 2D. This component is on a blueprint spawned off the character far outside the skybox. What I do now is disable ticking of the capture component on beginplay, and only re-enable ticking of it when the inventory ‘inspection’ window is activated on the HUD.

This means GPU Particles now collide correctly during gameplay.

Thank you so much for your solution. I have the exact same problem and your fix worked!

but what if the HUD should be always activated…? got any ideas?