Download

GPU Particle collision work in editor but not in play???

As the title says i’m currently trying to figure out why my GPU particle system’s collisions don’t work when in play mode. They seem to work fine while messing about in the editor but as soon as i try to “play” or “play from here” collisions break and they just fall through the ground. Below i’ve attached to screenshots, one outside of play mode where collisions work (as evident by the pooling of particles on the floor aswell as bouncing off of the prop) and another where its within play and broken. Does anyone know whats up or have any suggestions as to where i should look?
08a4c741e006437efca1e5ade7f98d9a3ca29dee.jpeg
ac7019d212d400a5eba59cb6a565e59778dc8aff.jpeg

Hey Zeth09 -

This is concerning, you should be getting collision via scene depth. Could you let me know what version of the Editor you are using and what version of Content Examples you are looking at as well.

Thank You

Eric Ketchum

Alright so I kept toying with everything i could think of to find a fix to no avail within my current project, fortunately its just a little test map so no harm done. I created a new project and everything seems to be working as expected, so my guess is i somehow managed to break something within the content example. Either way I’ll list the information requested just in case its some sort of compatibility issue with content examples.

Engine Version: 4.6.1
Project Example: Blueprint Third Person Camera
Migrated Assets: Marketplace’s Content Examples 4.6 (for the little showcase platforms)

While creating a new project seems to have fixed the issue I may continue to dig into the issue to see if i can figure out what went wrong.

I will also keep looking into it but if you happen to get a successful reproduction let me know the exact steps you used to get it.

Thank you for the report.

I had that issue during Beta and First RC. I don’t really remember this ever happening again but back then found a way to fix this but I currently can’t remember. If i experience it again will look into a possible quickfix artist side and report it too.

Maybe your engine scalability is different for PIE and for Play? I feel like particle collision might be getting disabled if for some reason the engine is trying to reduce visual effect quality…

It’s quiet possible with having the scale done automatically, Engine might set to max but when you get low FPS by default engine will try to reduce resources automatically thus leading to zdepth test being discared.

Still no luck reproducing the bug in another project. @DieByZer0 Don’t believe that’s the case here as I’ve no issues with frame rate. Current system is running a 980GTX, 875k core i7 w/ 8 gb at 1600 for ram. On the simple little map I have even during simulation i get anywhere from 70-120 frames (note frame smoothing is off).

I’m curious is there any way to visualize scene depth? How would I know if during PiE it was being discarded or not rendered? If there is no proper way to visualize it is there perhaps some sort of post processing effect I can use that also used scene depth in order to test if it’s being rendered?