Download

GPU Particle Collision Problem

hello
I have rain GPU Particle with scene depth collision. when I changed collision mode to distance field my particle starts flicking at the same place. Have you got any advice how to solve this problem? :confused:

here is a .gif

Have you checked to see if this happens when the effect is placed in a level? Also, have you enabled Distance Feilds in your UE4 project settings? If you have not done the latter, then this will not work. Tim Hobson, one of our Technical Writers did a really good write up on his blog about how to use Distance Feild’s particle collisions. Which you can check out using the following link: http://timhobsonue4.snappages.com/distance-fields-particles

Thanks for reply
I’ve checked in a level but still not working…Also, I’ve enabled Distance Fields… thank for the link I’ll take a look <3

I saw Thant but still not working for me :confused:

That link is dead. Also there does seem to be problems with Cascade particle GPU Sprite collisions in general. Mine don’t work either, be it distance fields or scene depth (at least not with the ground).

I also have flickering elements at Distance Field (Engine 4.21.2 / Intel)
It is unfortunate that Distance Field does not work on the mobile Vulkan.

Have to be sophisticated by CPU particles.
And the asynchronous ticking of the particle - does not work or on the edge of it the measure does not produce results. Also found no parameter FX.ParallelParticleCollision

In case people are still wondering. Collision on GPU particles only works if your particle material is set to translucent blend mode. for some reason…