Download

GPU overheating when running UE4

Hey guys, i have been wondering if anyone is having same problem as myself with GPU overheating when running UE4 in editor/game. I have two R 290 cards and generally if i have UE4 editor active and opened for while, card will run into high temperaturs over 80 degrees (even with fan running at over 70%). If i run game (editor-play) then it will switch into high heat almost emidently. Generally this does happen on some other high resource demanding games aswell. Its really annoying issue becouse once fans on cards start to run fast they are extremely loud.

Are you sure it is “overheating”?
If it is/was overheating the GPU should shutdown from thermal protection (overheating can damage the GPU).

Are you using the new Crimson AMD GPU drivers ?(Apparently it can cause GPU overheating and subsequant damage).

HTH

Hi janpec,

UE4 renders at default the editor as fast as the gpu can, which is often an unnecessary overhead. Try to restrict your max fps with the command ‘t.MaxFPS 60’ or even lower with 30.

Hope it helps.

I’m not familiar with AMD cards, but my GTX 970 maxes at 70 degrees with 60% fan speed in UE4. Have you checked to see if one of your fans isn’t working?

Thanks guys for input. Fans are working for sure, no problems there. Technically it isnt overheating becouse once the temp reaches very high fans start to ramp up which keeps temperature from rising, but it doesnt actually lowers it down so temp stays at around 80-85 degrees. I am using AMD drivers about few months old, not using the newest beta drivers which usually are problematic.

MrRabbit if i understand correct your suggestion will then cap my FPS rate to 30, which will prevent game from runing smooth, not sure if i want to be testing under such conditions.

Then those should be the “old” driver suit, Should be okay.

30FPS is about the minimum that you can go before obviuse smoothness issues are noticable.

HTH

You can cap it with ‘t.MaxFPS’ at any value you want not only to 30, you can cap it to your screen refresh rate e.g. 60. However if you are just developing it is not necessary to run the editor at 200 fps since your screen refresh rate is probably smaller.

Overheating is not software fault, it simply means the software is maximizing your GPU (which were never previously) so either you have to change your fan, remove the dust, change your cooling mechanism (use cooling fluid), etc… or undo the overclocked gpu.

Hm i did the FPS cap trick, if there is cap to 30 temperature does stay quite lower but still at 80 degrees. But 30 frames is noticably laggier. 45 seems to be alright as the minimum, but 45 already doesnt have any positive decrease for temperature.
By the way GPU is not overclocked.

I’m pretty sure there’s no way to make your hardware run faster, cooler, and more quietly. :smiley: If you want your machine to run cool and quiet you have to run games slower, run less demanding games, or get better hardware.

Are they reference cards? What does your computer case and cooling look like? Have you tried adjusting the fan profile?

You should probably check/clean your gpu heatsinks. (Maybe even replace the thermal paste with a high end one if you’re desperately trying to improve cooling.)

Turning off realtime rendering in UE4 main window and the thumbnails will also probably help use less gpu outside of playing the game.

Also if you’ve turned off framerate smoothing in the project settings, it will try rendering the game as fast as your computer can handle it, which will probably make your framerate go nuts on smaller scenes and use all of the power. I did that, on a pretty small map I was trying to optimize for lower end hardware, and my framerate shot up to ~600 or 1.5-2ms per frame, making my gpu do all sorts of weird noises and use 100% of my gtx 970.

Hey could you give me quick hint where i can find framerate smoothing under project settings? Did quick search but couldnt find it. Not sure that is gona make any difference though becouse i already tried caping to 60 frames and there was no change.

Most likely thermal paste/thermal pad under gpu heatsink has dried up. Or heatsink is clogged with dust. Or both of those.

Either clean up the dust and replace the thermal paste yourself, or find some computer repair service that can do that for you.

Not sure what does reference card means. My computer case is large and especially made for gaming 2+ card setup has many vents and is very cooled down. Well it does come down to fan profile if you look it from that angle. If i had set fan to operate on 60% from 0-60 degrees obviously this problem would be very limited then, BUT those fans on card are so loud, i mean it annoys me out even if i am using headphones, so for that i use 40% fan rate on 0-60 degrees. Its like sitting inside factory if its on 60+%.

Actually that does make sense, since those cards were few months used for Bitcoin mining, its likely that paste has dried off. Hm.

What version of the card do you have? Can you post a link to either a store page where you can buy the same version you have, or just an image. The reference 290’s are typically black with red accents and a red fan, reference cards run hotter, generally. There’s 2 main designs for GPUs, reference or blower style, which have one deep fan at one end of the card, designed to exhaust air out of the back, and non reference cards, which are typically 2 or 3 big fans that take up most of the card, designed just to remove as much heat as quickly as possible, and most of it goes back into the case.

Either design, you want to make sure your case and cards are getting sufficient airflow, cool fresh air coming in, and the hot air being exhausted quickly. Ideally you’ll want 1 more intake fan than you have exhaust, 2 intake and one exhaust is normally good enough for most situations (not counting your CPU/heatsink). See if having the side panel of your case on vs off affects the temperature a lot, that can point to airflow issues.

Also what are your CPU temps while the GPUs are at 80c?

Yeah, it probably wouldn’t do much if you already tried locking the framerate, but the place for the framerate smoothing is here anyhow:
Under the General settings tab, scroll to the bottom and there it is.

And a reference card is on the left and a non-reference one is on the right.

Yes in that case i do not have reference cards. My cards are as you described in second case, one fan located near rear with card being boxed altrough for airflow (red-black design). I can guarantee you there are no problems in regards to case being under-flowed, its case designed with upper, side and rear exhaust and there are 6 vents installed altrough it. Even the front is sucking some of it in since only 1 frame is covered with HDD, and the rest are free and semi-opened. I was not checking CPU temp to be honest, but i would hardly believe CPU has anything to do with it. It would need to go over 100 degrees to contribute to such quick and large temp increase on GPU. I do believe that having 2 cards is causing at least some of the additional problem, becouse those r 290 cards are large and quite close together so it does contribute to some, but active card is at 80 degrees while non-active is at 35. So even if i remove mostly non active one i might only gain a little, and the main issue is still somewhere else.

Thx for info, tried it, and as expected no change.