Gpu crash/d3d device removed error?

Getting “gpu crashed or d3d device removed” error instantly everytime I open UE5.

I used UE5 doing its preview, I used ue4.26 on a daily basis. This is new to me.

3 Likes

same issue for me

It’s because you’re running DX12, still haven’t found a fix apart from doing DX11 instead. Just go into deffaultengine.ini and change DefaultGraphicsRHI=DefaultGraphicsRHI_DX12 to DefaultGraphicsRHI=DefaultGraphicsRHI_DX11 for now and it should at least run DX11.

Edit: Swapping to studio driver and doing a windows update did the trick. But it still crashes randomly while prepping the shaders.

8 Likes

This worked for me – changing to DX11 in every UE5 project folder’s Config path.

Leaving it on DX12 with the latest Windows 10 updates and latest nvidia (non-studio, RTX 2080 Super) drivers had no effect and crash was still occurring.

I also tried removing UE5 and reinstalling to no avail.

Had no issues in Early Access :frowning:

1 Like

A long shot but I had the same issue and realised I had RTSS running.

After closing it I didn’t have this issue, until I ran RTSS again and loaded up a UE5 project.

It could be something RTSS is doing or another program potentially hooking in to get frame times etc

10 Likes

Oh man, awesome long shot (thank you)!

It was indeed RTSS (RivaTunerStatisticsServer), which I have been using at launch in recent months for some G-Sync game optimizations!

I’m still able to let RTSS run and do its thing and I no longer get UE5 d3d errors if I add a profile for the main UnrealEditor.exe as an Application Profile and set its detection level to: None

13 Likes

Nice! That’s a good shout, adding UnrealEditor.exe as a profile to ignore detection, saves having to exit it each time.

1 Like

I’ve tried this and am still getting an error.

Is this confirmed to be a DX12 issue?

Running a 1660TI card

Well, prior to changing RTSS (or stopping it), I did try the config file edit to DX11 and also had no issues (see above).

1 Like

Its when your GPU fails to render a frame, and CAN happen often if the VRAM cant respond in time for some Overclocked cards, or when your ram perhaps is damaged. I found I fixed this issue (which I didnt get in 4.27/4.26 but got every play of 5.0) was to underclock my GPU VRAM with the card manufactures software (zotec 1080ti amp oc for me, so i use firestore -100mhz on the ram.) GL HF

However DX11 would not work with Nanite.I’m stuck with this issue!

2 Likes

Either a lack of VRAM or your GPU is overclocked. I have an Asus RTX 3070Ti and without realizing it I have the OC version. which means overclocked by default. I downloaded the Asus GPU Tweek application and reset the frequency to normal and it is very rare that I get this error message now.

1 Like

Just go to the Nvidia Control Panel find UE app and set max FPS to the point it doesn’t crash. I’m using a 5-year-old GTX 1070 and I had to set it to 30 FPS.

The main cause could be that my graphics card is damaged. I started having this issue in some games after 2 years of building my PC (mostly the games made with unreal). Recently I’m having this issue in most recent games that require heavy GPU uses. Now I have to run everything in 30 or 60 fps.

4 Likes

thanks, solved here

In first test, work for me too

Having the same issue, nothing has helped so far.
MSI 3080 10G
Not overclocked, tried underclocking
NO RTSS or Afterburner
Tried setting 60, 30 fps limit via NVCP
Tried reducing render res & other editor options.
Any other ideas?

This certainly depends on the scene I’m running, lighter maps are okay. Other than that, not seeing any patterns whatsoever. Sometimes it lasts 10 minutes, sometimes it’s almost instantaneous.

2 Likes

Since you mention that you don’t have RTSS installed, you could perhaps install MSI afterburner and then the RTSS so that you can then try that option of adding the UnrealEditor.exe profile. In my case I already had the RTSS installed, and so when I added the .exe profile that solution has worked for me! (I have the AMD RX Vega64 gfx card - so the MSI afterburner is a great program for me) :grinning:

1 Like

I login to thank you :slight_smile:

2 Likes

same problem. gpu disconnecting. Sometimes black screen and I have to hard reset to turn it off.

No problems in UE4.27

RTX 3090
Rysen 7 3700x
32gb ram
win11

ps. Limiting the fps to 50 stopped the crash for me. It really works =)
60fps still crashes

1 Like

Re-import groom or click edit groom, this problem will occur