Download

GoogleVR crash with 4.21

Hi guys,

I have a big problem right now. I try to build a VR app with Unreal 4.21.1 for Samsung S7 with googleVR plugin. Problem is, the app gets build and everything, but it crashes on startup on my phone.
Creating the same simple Project from the QuickStart Tutorial with 4.20.3 everything works fine. My problem now is, I have a project made in 4.21.1 were I want to use the VR-Feature.
But I can’t downgrade it.

Has anyone an idea or a solution for me.

I’m thankfull for any hint.

+1

here too, same stuff

trying combo of different sdk/ndk, but no success till now

I tried to use the SimpleHMD plugin instead, but that one also doesn’t work correctly in 4.21.1.

Is someone out there who can confirme that this feature is working in Version 4.21.1 and can tell us what settings he or she is using?

Thanks a lot!

That’s interesting, because I have the same issue with Oculus Go - my game built with 4.21.1 (Oculus fork) crashes right on launch and it was working fine with 4.19.x. Crashes on render thread and I changed nothing related to rendering/visuals.

But, no worries, it won’t get fixed until 4.22 (and by then something else will be broken).

Just tried building for Go with launcher version of 4.21.1 and still getting the same crash when running build on the device.

Exactly the same problem on Xiaomi Mi5s Plus with Android 7.0. I have not found solutions yet. What version of Android do you have?

There is an option in the Project Settings > Packaging > Packaging for stripping off engine assets when packaging. Epic recommended (up until 4.20 I guess) using it to make apk smaller. After I unchecked it and repackaged my project, crash was gone and I can finally run it.

Do you mean “Exclude editor content when cooking” option?

Yeah, that one.

@motorsep thanks for the help, sadly that didn’t worked for me.
I had to create the whole project again in 4.20 where GoogleVR works totally fine. So sad that a feature that already worked, now makes such problems.

Same problem here. I think the GoogleVR plugin might need updating. I went to the Google VR, UE4 section and it says build from source, but this person already tried and got the same result. https://github.com/googlevr-unreal/U…gine/issues/43 If I remove the Google VR plugin the app loads. If I run ue 4.20.3 it all works and it also works with the new Codeworks 1r7u, so that update had no effect.

4.22 same story, app that worked with 4.20 crashes in 4.22 because of GoogleVR plugin on lots of phones.

Not sure if this is related. I updated my project from UE 4.19 to 4.22. The 4.19 versions starts well with my GearVR and S7edge. On 4.22 it quits right on start up mentioning possible problems with the app signature. So I rebuilt the OSIG key for my device, placed it into the project files as before, but I keep getting the same message. The project still runs well when tested on pc.