Download

[GOOGLE VR] Widget Component crashes project once deployed

I made a simple basketball game with the new Google VR Daydream tools and I am testing on a Motorola Nexus 6 running Android N preview 5. I made an actor with only a Widget Component that displays the team score and it crashes the project after 2-30 seconds. I made a blank project with only an empty Widget Component and it produced the same result. I’ve tried literally every option available (blend modes, render pass, etc) and while it does last a bit longer with all the widget and post-processing effects off, it still crashes every time. Can anyone try to reproduce this issue for me or provide any insight on what’s happening? As you probably know there is no good way to do menus in VR without widget components in 3d space. I tested it on a Samsung S7 Edge with the same result. Thanks!

EDIT: This does not happen in editor, standalone, or launched to PC.

I would suggest you post on the answer hub and file a bug report although I doubt it’ll get fixed as 4.13 brings with it a completely new Widget Component I believe so you might have to wait until then

Thanks for the reply! I have already done both and I guess I’ll just look forward to the Widget Component rework! For those who are having the same issue, just use a text render component in actors with a line trace on the player to make temporary menus.

I found this a while ago as well. There is a cherry pick for the fix here:
https://answers.unrealengine.com/questions/431216/daydream-412-crashing-project-when-imported-from-4.html
hopefully will be in 4.13 though by default.