Download

Google-VR packaging fails

Hello,

I’m trying to package a test project for Google VR but it fails.

My Unreal Engine has a specific version (4.13-google-vr branch), I followed this guide: https://developers.google.com/vr/unreal/get-started
And I also followed this guide to configure my project: https://docs.unrealengine.com/latest/INT/Platforms/GoogleVR/QuickStart/2/index.html

The only one thing I change is the NDK and SDK versions. Google says to use android-24 (but I also tried with android-21 which gives me another error) so i changed my configuration to use android-24.
This is the error I get during the packaging:


UATHelper: Packaging (Android (ATC)): UnrealBuildTool: -compile:
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] Compiling 47 source files to C:\Test\TestProject\Intermediate\Android\APK\bin\classes
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] C:\Test\TestProject\Intermediate\Android\APK\src\com\epicgames\ue4\GooglePlayStoreHelper.java:181: error: cannot find symbol
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac]                 response =  mService.isBillingSupportedExtraParams(7, gameActivity.getPackageName(),"inapp", bundle);
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac]                                     ^
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac]   symbol:   method isBillingSupportedExtraParams(int,String,String,Bundle)
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac]   location: variable mService of type IInAppBillingService
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] C:\Test\TestProject\Intermediate\Android\APK\src\com\epicgames\ue4\GooglePlayStoreHelper.java:184: error: cannot find symbol
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac]                     buyIntentBundle = mService.getBuyIntentExtraParams(7, gameActivity.getPackageName(), ProductID, "inapp", devPayload, bundle);
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac]                                               ^
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac]   symbol:   method getBuyIntentExtraParams(int,String,String,String,String,Bundle)
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac]   location: variable mService of type IInAppBillingService
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] Note: Some input files use or override a deprecated API.
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] Note: Recompile with -Xlint:deprecation for details.
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] 2 errors
UATHelper: Packaging (Android (ATC)): UnrealBuildTool:     [javac] 3 warnings
UATHelper: Packaging (Android (ATC)): UnrealBuildTool: 
UATHelper: Packaging (Android (ATC)): UnrealBuildTool: BUILD FAILED
UATHelper: Packaging (Android (ATC)): UnrealBuildTool: C:\NVPACK\android-sdk-windows	ools\ant\build.xml:716: The following error occurred while executing this line:
UATHelper: Packaging (Android (ATC)): UnrealBuildTool: C:\NVPACK\android-sdk-windows	ools\ant\build.xml:730: Compile failed; see the compiler error output for details.
UATHelper: Packaging (Android (ATC)): UnrealBuildTool: 
UATHelper: Packaging (Android (ATC)): UnrealBuildTool: Total time: 22 seconds
UATHelper: Packaging (Android (ATC)): UnrealBuildTool: UnrealBuildTool Exception: System.IO.FileNotFoundException: Le fichier 'C:\Test\TestProject\Intermediate/Android/APK/bin/TestProject-debug.apk' est introuvable.

I hope you can help me to find what’s wrong !

Did you manually install NDK version 24? This is not installed by default in the android codeworks