Google-VR Build-Failed!

I’m New Here and i tried to make a Little VR-Project!
… The whole day i was installed MS-Visual 2015 Community…
… Yesterday i was installing everything else! “NVPACK” etc.

so i followed this Guide! QUICK-START-GUIDE

After all that, i was make the SAME Things like this Guide for maybe 12 Times, with other settings like “matchndk” and “latest” etc. but… there is ALWAYS an Error!
i Can’t get it! i don’t know why or what is happend! The only thing i know is, That the Log-Files shows me an Error!


i Hope Somebody can help me =/

i don’t get it…
i don’t know what the problem is! … can’t figure it out…

HI CemOoOoOo,

GoogleVR was not packaging correctly for 4.12 Preview 5. When I tried in our latest Preview/Release Candidate that will be available later this week I was able to package for GoogleVR.

Once this version releases can you try packaging again for your project. If that fails, please make a blank project and try packaging there as well. This can rule out if it’s a problem with your project or not.

Thank you!


Okay there is an update available today!
i try to pack it with that “release” of 4.12.0

May it helps!

I’ll try exactly the “Quick-Start-Guide”…
we’ll see!

i’m back in a hour!

MainFrameActions: Packaging (Android (ATC)): UnrealBuildTool: BUILD SUCCESSFUL
MainFrameActions: Packaging (Android (ATC)): UnrealBuildTool: Total time: 1 minute 22 seconds
MainFrameActions: Packaging (Android (ATC)): CommandUtils.Run: Run: Took 163,176937s to run UnrealBuildTool.exe, ExitCode=0
MainFrameActions: Packaging (Android (ATC)): CommandUtils.Run: Run: E:\Spiele\Epic Games\4.12\Engine\Binaries\DotNET\UnrealBuildTool.exe VRProject412 Android Development -prepfordeploy -project=“D:\Unreal Projects\VR-Project\VRProject412\VRProject412.uproject” -NoHotReloadFromIDE -ignorejunk
MainFrameActions: Packaging (Android (ATC)): UnrealBuildTool: NDK version: 21, GccVersion: 4.9
MainFrameActions: Packaging (Android (ATC)): UnrealBuildTool: building WITHOUT VULKAN define

Now i have to wait for my girlfriends LG G3

Quick Question! … How to build with Vulkan?
in the Last MainframeAction you see “building WITHOUT VULKAN define”
… how to build WITH?

Hy, I am having similar issues! and Im already getting bold trying to solve it :stuck_out_tongue:
I am using UE 4.12.5 I have installed all SDKs NDK etc. … I can successfully build to whatever without the GoogleVR plug in on.

So when I set my android SDK to ‘android-21’ then it builds, but cannot deploy(when copying the apk a parsing error comes up). with ‘android-19’ it doesnt even build ( yes the correct SDK is installed ).

any ideas?

( sorry for sharing the code like this, I couldnt attach for some reason, this is the last bit of the Log )

MainFrameActions: Packaging (Android (ETC1)): at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask)
MainFrameActions: Packaging (Android (ETC1)): at BuildCookRun.DoBuildCookRun(ProjectParams Params)
MainFrameActions: Packaging (Android (ETC1)): at AutomationTool.BuildCommand.Execute()
MainFrameActions: Packaging (Android (ETC1)): at AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands)
MainFrameActions: Packaging (Android (ETC1)): at AutomationTool.Automation.Process(String[] CommandLine)
MainFrameActions: Packaging (Android (ETC1)): at AutomationTool.Program.MainProc(Object Param)
MainFrameActions: Packaging (Android (ETC1)): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
MainFrameActions: Packaging (Android (ETC1)): at AutomationTool.Program.Main()
MainFrameActions: Packaging (Android (ETC1)): Program.Main: AutomationTool exiting with ExitCode=5 (5)
MainFrameActions: Packaging (Android (ETC1)): Domain_ProcessExit
MainFrameActions: Packaging (Android (ETC1)): copying UAT log files…
MainFrameActions: Packaging (Android (ETC1)): BUILD FAILED
PackagingResults:Error: Error Unknown Error

When targeting android-21 you should be targeting ATC. Does this build for you?

Also, you can attach logs to the post by using the paperclip and uploading the text file for the logs.

Here is my tutorial for engine version 4.14: Unreal Engine 4 GoogleVR packaging for distribution - YouTube
Hope it will help.