Google Play Loggin


I am near to end of dev for my game, i set-up my config like this for google play:

And in my blueprint:

I packaged my game for distribution, its on the store in open beta, but when I launch the game, there is no google play login that shows up, I can’t get the google play menu to show, and found no tutorials on how to actualy set-up correctly, i searched all the posts and did what they say, but dint help, if someone would have any idea,


I had wrong app id, change it BUT still not working, nothing even shows up, that the weird thing, my app is published, the config are all set nice, but googplay service dosn’t show up :confused:

Searched all day, didn’t find a fix ( I have to pakcage and upload it to the store evertime i want to test) o_o driving me insane aha

Or maybe someone who has google play up and running that could take me step by step the way they did it,
I already have the google app ID and certificate number and keystore is placed in the correct folder.

Bumping :confused: havn’t found a fix yet

Hi, have you tried not to use the ‘Do Once’ node? sometime it takes multiple tries to actually connect, and auto login the user/show login

Hey, thanks for the response, i actualy took the login blueprint from match3 (very simple stuff) put it in maingamemode as an event and send it to begin play on start main map, and i even aded a button to connect, when clicked do the custom event, but neither on begin play nor button pressed shows the loggin ui

I also checked the google dev console, seems that all is correct, i just can’t figure out what im missing!

Maybe i (admin account) has no acces to google play on my own game? Try downloading the night run on google play see if the window shows up!

I had an issue for a while where the login screen wouldn’t come up. Then all of a sudden poof and it did while I was changing other Android settings. It’s so obscure and so few people seem to have this issue like you and I that I’m still not sure what the hell i did to make it work. It’s real frustrating.

D.amn, you wouldn’t have any hints ? Where you changing things in UE4 ? or google play console?

Thanks for the answer!

Haha, I used to have the same problem! It’s very annoying that it’s pretty bad documented and you keep being referred to the Tappy Chicken example.

On EventBeginPlay > 
    If > Is Logged In (GetPlayerController)
        True > 
        False > Show External Login UI (GetPlayerController)

That is actually all you need to get the login screen popped up.
You could also try to add a UI button that does this.

OnReleased > 
    If > Is Logged In (GetPlayerController)
        True > 
        False > Show External Login UI (GetPlayerController)

Small side node:
Don’t forget to invite yourself to your beta, your dev-account is not automatically alpha/beta participant.
For myself, I’ve 2 google accounts. 1 for access to dev console, 1 i actually use on my phone and use for alpha/beta testing.

It is released in prod, and i am a beta tester in the list, and i have blueprint set up like this:

Begin play main menu map blueprint:

MainGameMode event:


Store if not connected connect then buy:


(dosn’t show loggin menu)

And the thing that i just realized is that when playing on my phone after downloading it from store when pressing connect to google play button (umg that i made that should show ui loggin) none of the strings show up after pressing button or on begin play, (strings after failure succes and continue of ui login node).

I’m having the exact same problem. I’ve got my game uploaded to Googles Servers, in Alpha, I’ve got what seem to be all the correct APIs. And all the accurate information about my app in the Android settings of Unreal 4. But the Login UI never shows up after being called. It just automatically gives me the On Failure result. The interesting thing, I’m using the exact method that I copied verbatim from the Unreal’s official Match 3 example:

This has been a constant thorn in my side, and I even followed Vipar’s tutorial to a T: (Integrate Google Play Services with Blueprint - Community Content, Tools and Tutorials - Unreal Engine Forums) hoping that it would be my saving grace. So please, if anybody knows what might be causing this issue, I’d be eternally grateful for any information leading to a solution. Please and thank you.

I abandoned the idea of google play, and the in game store, i had to make it .50 cents to buy game -_-

Good day, hopefully one day we will find a fix for this “bug”?


Sampuig, I wouldn’t give up.

Does anyone know how to fix this?

Is it hopeless to try and make Android IAPS in UE4 currently?

I have to, i am moving country soon and won’t have my computer, so i have no time so i released my game for money now :confused:

And no one has found a fix for this yet :confused:

luck/insane attention to detail
The combination of the above made logging in for googleplay work for me when I launched the game from the editor to my cellphone, haven’t checked packaged game yet.

I have went threw those many times mate, i’ll try again in the morn, thanks!