Good FPS on editor but bad FPS on packed project

Hello! Hope someone can help me with this…

I have a GPU RTX3070, I made an archviz project, and the thing is…

If I play the project on the editor viewport inside Unreal, the FPS are good enough to play smoothly, around 40-50 FPS on the hardest areas where there are way a lot meshes, lights and reflections.

But when I packed the project and start it on windows, the FPS on that areas get too low, probably around 20 FPS, so it´s kind of frustrating, because I tried to optimize it, with LOD, textures, lighting, DLSS…

I don´t know what is causing that problem, It´s like my GPU is not working enough when the project is open on windows, but inside Unreal editor, is good enough to work and play it smooth…

I don´t understand it, because the project is an archviz house project, so it´s not way to heavy, the RTX with the nvidia plugins are installed, and it runs so good on the editor, but so bad on the packed project, so I will not be able to make a presentation with it.

Thanks, hope someone can help me, I don´t know what else to try…

When you go into the folder of your packaged game (PACKAGEDGAMEPATH\Saved\Config\WindowsNoEditor) and open the GameUserSettings.ini you could try to lower some of the settings and set the max fps.

[ScalabilityGroups]
sg.ResolutionQuality=100.000000
sg.ViewDistanceQuality=2
sg.AntiAliasingQuality=2
sg.ShadowQuality=2
sg.PostProcessQuality=2
sg.TextureQuality=2
sg.EffectsQuality=2
sg.FoliageQuality=2
sg.ShadingQuality=2

[/Script/Engine.GameUserSettings]
bUseVSync=False
bUseDynamicResolution=False
ResolutionSizeX=1920
ResolutionSizeY=1080
LastUserConfirmedResolutionSizeX=1920
LastUserConfirmedResolutionSizeY=1080
WindowPosX=-1
WindowPosY=-1
FullscreenMode=1
LastConfirmedFullscreenMode=1
PreferredFullscreenMode=1
Version=5
FrameRateLimit=30.000000

........

Thanks a lot, you made my day! Trust me! Thanks a lot!

2 Likes