Download

Glow materials flickering when player moves

Sorry, its not only for glow materials, for all materials in my game.
What could cause this problem ??? I am using only force to move and simulate physics are enabled

Just check images :

When player moves the white color as you can see on this image sis shuttering , flickering, twitching… take the word which you want…

Screenshot_2.png

But when i stop its normal :
Screenshot_3.png

Material properties
39229b8f618eec7915dae29097492f4ab1e741d8.jpeg

It is probably due to temporal antialiasing. Temporal antialiasing “averages” scene over many frames, what is super for achieving metallic shiny look but has some drawbacks, like the one you have described. Put PostprocessingVolume to the screen, make it unbound (affect while screen) and change the settings for temporal AA to MSAA (or no filtering). It is under advanced settings i think (just search for antialiasing). If you game does not have metallic surfaces, this might work better. You can probably also change the setting on per-project basis in rendering settings (don’t have access to the editor atm to check it out).

With that said, you will probably want to keep temporal AA if you have metallic surfaces. You can probably tweak some parameters though (like how the images get composited). When the scene is more full, the anomalies is less apparent in my experience. Hope this helps.

Results :

1.Not moving :
92a8c3900a703e625ff260a742cb94ec270a9bcc.png

2.Moving :
Screenshot_6.png

3.PostprocessingVolume properties :
Screenshot_8.png

You see the difference now, Now its less and i think its OK for my game. Players will not pay attention to that, Because it looks like a trail or something.

It was not only player shuttering it was everything else aswell. If i click on top of the box as you can see on image below, the other orange lines were flicker except the top one that is selected. But now that is fixed
Screenshot_9.png

And yeah i forgot to thank you !!! :smiley:

All of that up there, didn’t totally fix my problem, but i resolved it my self.

Besides everything other that i did (Read 1st reply), In PostProcessVolume in search textbox write down “Motion” and you will have 3 grayed out properties. Enable “Amount” and set it to “0”

Here is the image :
Screenshot_2.png

THIS TOTALLY FIXED ANY BLURING