Download

Glitches with trees

What happens to the trunks and foliage of trees? How to fix it?

And one more question why do trees have such a blurry texture? In a blender, it looks completely different, better!

probably your LOD is kicking in because lower screen percentage, and you’ve set the LOD to cull out certain parts of the tree before others.

the lower resolution is likely do to some export settings. Maybe you’ve packed into an atlas and it should be a larger size?

are you using some sort of tree creator app?

I created them all in Blender, but as you can see, the rest of the trees are working fine. I cannot understand what the problem is and what I should do to correct this misunderstanding.
What about textures? Why do they look better in Blender?
The texture resolution is the same: In Blender and Unreal engine.
With trees, this also happens in debug mode, that is, when the game is not running.

There are a number of things that can be improved in this scene. It appears that the trees are skeletal mesh actors. This is not necessary and is actually very expensive. I would look into setting them up as static meshes so that they can use the foliage system. You can still have the wind animation play via a material.

The materials being lower quality could be a number of things. If the texture itself lower quality it is likely because unreal does automatic texture compression. Check your texture settings and ensure the proper compression is chosen. If the Texture is fine and the material is lower quality when applied, it’s probably a setting on the mesh. Like @BIGTIMEMASTER said, this could be due to LODs

If you apply the material to a cube and it still looks blurry, then it’s probably something in the material or texture.

The Trunk going invisible is likley from a Bounds issue and having them cull.

Where can I find the texture compression settings?
And how can I change the settings of the cull trees? By the way, I didn’t change anything there.

In the texture there is a dropdown for compression settings. You can read more here:

Visibility Culling is a bit more complicated as there are a few methods for that. You can check them out here:

If it is an LOD setting you can see how to set up LODs for static meshes here:

And if you want to keep it as a skeletal mesh there is information on how it is done here:

can’t find where to check texture compression in settings?
How do I turn off texture compression?

If you open up a texture it’s on the right hand side

image

Thanks!
How do I turn off texture compression?
There is no sense to go there, all textures are compressed by default for some reason.
In general, this is some kind of software glitch, apparently when an object is selected, it stops being removed, and even when the camera is turned to face it, for some reason it disappears, the clipping boundaries here cannot be the reason

Unreal is a real time engine so there are some things that are built in and kind of defaulted. You can’t really “turn off” the compression settings. It’s part f the import process. You can however ensure they are using the maximum size, There is a chance that mipmaps are the issue there.

Look into the Level of Detail settings on the texture. Try setting the Mip Gen Settings to no Mipmaps or changing the texture group


Great, now everything has disappeared altogether except for the tree trunk, I will most likely return back to gms 1.4

I would recommend you take your time to learn more about

  • Unreal’s Static Meshes
  • Unreal’s Skeletal Meshes
  • Unreal’s Materials

Instead of quitting that early, rushing stuff will only set you back and delay you more