Download

GI not working in new scene.

Hey guys,

Now I am having a very irritating issue where GI will work fine in one scene but doesn’t work at all in another. Here are some screenshots to show what I mean. I am using (virtually) the same setup in both scenes. One light, light importance volume, post process volume, atmospheric fog and the BP_sky sphere. Another thing I should mention is that the shot with working GI has a very large terrain with light resolution cranked to 3. The terrain without GI is maybe 1/3 the size with res up to 2 but I am getting some nasty results.

Thank you for your time.

What’s your lighting setup? Do you have a skylight, ambient cubemap or Environment color enabled?

Thank you for the reply DanielW,

I have one directional light which is linked to the sky sphere. But no ambient cubemap and the Environment Color (Im guessing the one in the world settings?) doesn’t seem to do anything. I’ve also adjusted indirect lighting (even cranked it) in a few areas but I still get nothing.

The major difference is the first scene is from a template and the second is from scratch (since for some reason I never got an option for a template when creating a new level). I did some research on learning more about the Volumes and Visual tabs in UE4 but I couldn’t find anything about them. Is it possible to point me in the right direction?

Thanks again.

Here is an update. I added a skylight and even a post process volume for the AO cubemap. Still all I get are black shadows on the back of my trees. I even cranked up the environmental light color to white with no resolve. Here is a screenshot. I have both my skylight and main directional light set to Stationary so I’m completely at a loss here. I’m not even seeing any decent color bleed.

PS. I adjusted the terrain resolution to 4 and I still get blob/ choppy looking shadows on the terrain. Does it really have to be this difficult just to get some nice looking shadows/ lighting?

Hi All…I’d like to say I’ve got a similar thing too happening with Speedtree Trees. Unlike Killer Ferret my shadows on the Landscape is fine but the back of the trees is strange…I have an example of one tree I quickly did up as a test and you can see half is lit correctly but the other half of the exact same tree in the same position is black. If you look at this image: http://screenpresso.com/=zJEVb it shows it. Like wise with Killer Ferret I’ve upped the GI bounces, no go. I’ve got a skylight…still no go. Heck I even went the extreme and put in a second directional light, turned off shadowing on it so it could be used as a bounce light and STILL no go. It’s not happening to all. It only seems to happen to one’s like say an Acacia tree where the mesh planes usually run flat. I am aware that usually you need to align the vertex normals but Speedtree should take care of this. Any clues?
Thanks Regards Shez

Hi Shez,

I’ve not been able to reproduce this at the moment.

In my scene I’ve used the Conifer desktop model that’s free from SpeedTree’s asset store. You can download the Tree pack here.

b8ea399a6c84e4774c8391997ff7d14b50120d0b.jpeg

For my scene setup I did the following:
I used the default scene for a new level
Imported the Conifer Desktop from the pack
Placed this in the scene
Placed a skylight
Built Lighting

Can you try the conifer tree from the pack and confirm that you’re seeing the same thing? If you get the same shadowing as I have and it’s not black can you use the Acacia tree you’ve got next to it for comparison. This way we can rule out if it’s the tree mesh or something in the current scene you’ve got.

Once you’ve done this we can move on and test other areas if this isn’t the issue.

Let me know how it goes! :slight_smile:

Tim

Using a skylight with cast shadows set to false and intensity 1-2, works pretty good for proper SpeedTree lighting. Also, having cast static shadow set to false and cast inset shadow set to true, can be used for dynamic shadows, but that is probably not suited for a whole forest.

Hi Tim,

Thanks for that. I have placed the default Speedtrees that come with the free UE4 Speedtree pack in and it seems to work fine. It’s when I start to generate my own leaf planes it starts to play up. However in saying that that Acacia test I did I changed the leaves to one that comes with speedtree in their mesh bits and pieces and the result I got was what I posted. Half the tree was fine underneath but the other half was black. I even turned off AO in case it was affecting it but still no go. Just so weird. Oh and I changed the leaf material to be SSS and plugged the diffuse into the SSS slot as a test and same issue…half black and half fine.

Regards
Shez

I’m having the same problem. Seems like a pretty big bug to have no fix.