Ghosting in UE5

Hello there,
I only do cinematic with UE so realtime performance isn’t an issue for me. I noticed the ghosting happened a lot compared to UE4!

Doesn’t matter it’s Temporal AA or FXAA, both produce ghosting and the image quality looks worse in FXAA when it comes to fast moving objects. Only None Anti Aliasing mode will not ghost so far, but it will have flicker here and there.

I think I will stick with TAA because it’s like the best AA mode thus far. But I am quite clueless how to anti-ghost in TAA. I have looked around but find no solution. Tried input tons of console command, but it will not work. These:-

r.TemporalAASamples
r.Tonemapper.Sharpen
r.TemporalAACurrentFrameWeight
r.PostProcessAAQuality
r.Tonemapper.Sharpen

In one of the discussion I have read. Some pros commented that Temporal AA really relies on a correct input of velocity vector? But I have no idea what it means.
Please help

Are you using Lumen?

Certain features in Unreal have strong temporal filters that will ghost regardless of your AA settings, and there’s not a lot you can do about it without tanking the quality.

Lumen is one of those features.

On fast moving meshes you can disable “affect distance field lighting” to somewhat mitigate this but it won’t get rid of it.

1 Like

Unfortunately yes… I’m using Lumen.
Will try your suggestion, thanks!

For what it’s worth, as far as I know Epic has not really gotten around to setting up Lumen for cinematics yet so the ghosting (and other issues like warm-up from camera cuts) will hopefully be improved in the future.

Also forgot to mention, if you have a sudden bright light (muzzle flash from a gun for example) epic recommends setting the indirect lighting intensity of the light to 0. That may help with lingering lighting.

Hello,

Not sure if this has been resolved for you folk but I do ArchViz and I have issues with window frames & mullions but not anything else.
The common factor with all windows is glass of varying transparency.
Glass with zero Opaqueness does not cause ghosting in UE5. The down side is that even transparent glass is not totally transparent as it also reflects. Transparent glass is NOT photorealistic.

I model in ArchiCAD and use DataSmith and I suspect that the conversion is a possible cause… or ArchiCAD. When I have time to experiment I will try different export methods such as ArchiCad to Twinmotion to UE5 either as a whole model or as separate windows and report back.

Cheers

Hello folks, i’d just like to chime in here (and on other similar posts ive found) in case it helps someone else (as i also tried finding a solution to this).

TLDR: Upgrade / Downgrade your nVidia drivers until you find a version that does NOT produce ghosting. Good for devs? Yes. Bad for end player / customers, as you have to “force them” to use a certain driver version to run your game as intended? Yes…
516.59 = Zero ghosting
527.56 = Extreme ghosting

For me, i had EXTREME ghosting, i’m talking 2 centimeters (real life scale on my monitor) of ghosting from a mountain in the distance against the horizon).

I knew this was peculiar, because i had only noticed it after i built the game my first time, and checked my old dev footage and didnt notice any ghosting at all.

Re-recorded a snippet, to see if it appears in footage, and yes it did.

So what was changed after a long hectic workday where its easy to lose track?

  1. Installed Visual Studio 2022
  2. Installed new nVidia drivers

Guess?
Yes, it was the new nVidia drivers.
Previous drivers 516.59 = Zero ghosting, even when moving the camera fast.
New drivers 527.56 = Extreme ghosting. Nothing else changed, no nvidida settings changed.

1 Like

Thank you. I thought this changed at some point. Will try the older driver.

This didn’t help unfortunately. Maybe I need to recompile with the new drivers.

A youTube video from William Faulkner solved this for me:

The fix was changing PostProcessVolume/ Translucency/Type from Raster to Ray Tracing.