Download

Getting terrible jagged edges on far corners

Hi everyone,

My project is running on UE 4.12.5 for Win64bit deployment. In one scene in my level I get terrible jagged edges on the far corners of the room. I have a postprocess volume doing Temporal AA and my settings are on EPIC for texture quality and AA. I have also built the lighting on ‘HIGH.’ I’m using static and stationary lighting on this scene.

My level has 3 streaming levels and my postprocess is on the persistent level. I have confirmed that my volume is affecting the scene by doing a scene tint - so the temporal AA should be applied here. I have also tried switching to FXAA and the issue is still there.

As you can see on the pictures I’m still getting terrible edges (both in editor and Game Mode). It only seems to happen on those corners and not on the pillars or other geometry.

What am I missing?

Would appreciate any help I can get.

Thanks!

-Jorge

You can watch a short video to see the problem in motion here - [https://youtu.be/UPfVIArn1tE][1]

5f52d841650c54effc68aa68158aebf3a8b53f0e.jpeg
0bab59f1a8db8f206b15fc229eecd3bfd044fa35.jpeg

Do the jaggies go away if you fly nearer with the camera?
It looks like your level is huge, and you’re suffering Z precision issues.
First, make sure you’re getting 24-bit (or better, 32-bit) Z precision, and not 16-bit precision. (You need to search the engine documentation about this; I forget how and it’s not super obvious)
Then, push out the “near camera distance” to make it better. Settings -> Engine -> General Settings -> Near clip plane.
I think it defaults to 10, you need it at at least 100.

If the jaggies are there even when you’re near, then the problem is likely light mapping or shadow map resolution.
Make sure to follow all best practices about Lightmass importance volumes, maximum light map resolution settings, etc, if that’s the case.

If it is the depth z fighting which I also suspect, creating a sealed box rather than using intersecting planes should fix it. That means the edges need to be stitched together. Or just cover it with some kind of trim and call it a day.

Thank you so much for your replies jwatte and Ryan!

As you both suspected, it was Z depth fighting. My near clip plane is set to 0.1 since I get really close to objects for inspection. I made the room a single mesh via Merge Actors and that helped but did not solve the issue. At the end, I added some trims like Ryan suggested and that solve the issue.

Thanks again!

-Jorge

ac50b21a761fbbfe9b3ba7038693b9c38dc94b02.jpeg