Getting Stuck on Light Build Status

I keep freezing on this screen. The “Swarm” executable is displayed in my system tray, but I have no idea why I keep freezing when ever I do a light build. I even created a fresh scene and it still does it. Any solution? I’m stuck:

As I continue to self-toubleshoot, here is my swarm agent log file. I have tried bypassing UE4 from firewall and have verified no other Swarm Agents are running by viewing the task manager. Also verified my computer name has text in it, and not just numbers. Any suggestions please? My architectural project has come to a grinding halt as I am unable to do light testing/builds.


Update - Tried restarting several times with various adjustments including changing computer name from Delta-W7 to DeltaW7. Still doesn’t work. Tried deleting cache files from C:\users >> Swarm log files. Still doesn’t work. Uninstalling EU4 and redownloading… Hope this helps.

By the way, am I in the right place for this type of issue?

-have you also checked the processes tab in the task manager -> when there is a 2nd swarm agent, close it
-make sure to take a look at this thread: https://answers.unrealengine/questions/124139/cant-build-anything.html
-post your problem on answerhub: https://answers.unrealengine/ :slight_smile:


I wasn’t getting a second swarm agent in my task manager. I have also posted this on the answerhub. Hopefully I can find a solution here. Thanks for replying!!

I will just post the answerhub link in there: https://answers.unrealengine/questions/197165/getting-stuck-on-light-build-status.html :slight_smile:


Thank you for doing so! As I have been spending all day trying to fix the problem myself. I haven’t had any luck. I’m running out of ideas and would very much like to complete this project with Unreal. Obviously baking the lighting is a requirement for me. I’ll keep researching and keep my fingers crossed on a solution.

Part of my research showed another user who had the same problem, but unfortunately the solution for him was not the same for me - https://answers.unrealengine/questions/56918/build-not-working.html#comment-57513-form

Though reading through this issue the Epic Staff member referenced nothing should use port 8008. But I noticed on my computer “System” is using 8008. Here is a screenshot of my network monitor. No idea what to do since I can’t end the “System” from the task. So any suggestions would be greatful.

I have resolved this issue. I contacted an I.T. personal within the company I work for and he made a change to a setting on our network. This apparently allowed the port 8008 to become free and Swarm Agent is now working again. Unfortunately I do not know the exact details of what changes he made as it was resolved over the phone.