GetRandomPointInRadius doesn't work correctly

Hello,

I think there is something bad happening because Get Random Point In Radius (BP node and C++ function probably too) sometimes does not change input origin and just sends it to output, so return value is not random point. This happens in about 50% of cases.

It is very easy to reproduce, just add following nodes (see screenshot) to controller of top down template. I also attached my project.

Tested on versions: 4.4.3, 4.7.5

Screenshot:

Project (50mb):

Hi Nonder,

Thank you for you report. I have recently seen a lot of fixes for broken “random” location choices so I tested this in 4.7.5 and our internal branch. I could see the exact problem you are showing here in 4.7.5, but luckily when I tried again in our main branch, the points were completely random and no longer had an obvious trail. This is currently available via GitHub, but it is not well tested for other bugs.

Please let me know if this still occurs for you after our next full build is released.

Cheers!

Yeah, I’ve already fixed it :smiley:

Thank you! Glad it is fixed, finally I will be able to remove that ugly condition if(Origin == RandomPoint) then ignore that and try again :slight_smile: