GetLifetimeReplicatedProps

I think that’s a just a Visual Studio intellisense error squiggle - not an actual compiler error. Have you tried compiling?

So I’m a bit confused here. I’m just adding onto the Introduction to programming series.
After digging through both these links: [Networking/Replication][1] // [Networking Tips and Tricks][2]. Followed up by digging through the code in the Shooter Game. I cannot figure out why I’m getting “GetLifetimeReplicatedProps Error: Inherited member is not allowed” issue.

void ATopDownGameCharacter::GetLifetimeReplicatedProps(TArray< FLifetimeProperty > & OutLifetimeProps) const
{
	Super::GetLifetimeReplicatedProps(OutLifetimeProps);
	DOREPLIFETIME(ATopDownGameCharacter, PowerLevel);
}

Everything I’m reading, and seeing in the code does not suggest GetLifetimeReplicatedProps should be in a header somewhere (for that matter i tried and it says it’s declared elsewhere). Anyone have any suggestions?

I’m really just working toward syncing the power level from the tutorial. The game compiles fine and runs power level doesn’t sync at this point but I’m not sure if this is a direct correlation or not.

EDIT: as a side note, I applied the tutorial series to a top down game template rather than 3rd person.

Hi, did you try to include this one ?

#include "UnrealNetwork.h"

I did. I also tried (used in the shooter game):

#include "Net/UnrealNetwork.h"

I switched to include:

#include "Engine.h"

rather than:

#include "EngineMinimal.h"

Both the net and engine include are in TopGownGame.h which is included in the TopDownGameCharacter.cpp (where this error lives).

It does compile (I’m a bit of a chronic compiler). I do have intellisense turned off in the Error list output (context click->show itellisense errors).

After enabling Itellisense errors, it does show as an error related to intellisense. Odd that it doesn,t show when I compile Shooter Game though.