Get error when use 2 post process in the same level

when uses two post process in the same level, ue4 don´t open the level, freeze.

someone get the same error/freezing?

When create in 4.12.2 not occurs the problem but when level comes from 4.10.4 the problem appears

Blank Project with error.

only need to do is open level NewSkyEffects2.umap

  • when postprocessnight don´t set cubemap HDRI_Epic_Courtyard_Daylight the problem not appers. if don´t check tint and intensity resolve too i don´t know, very strange.

Hi Chicolinohehe,

I’ve just tried this with 4.10.4 and opening a copy in 4.12.2 without any issue. I’ve only got two simple Post Process Volumes that slightly overlap and the only setting in each that I’ve adjusted is only changing the scene color.

Opening the copy in 4.12 shows no different or freeze when trying to load.

Can you try this yourself in a blank project in 4.10.4 and open the copy in 4.12.2? This can rule out of if there is somethign else in your project that is causing the map to fail to load. You will also want to look at your output log and see what it reports when you try to open the map file. This may have a better indication. Aside from that, with the freeze you could just try to open and wait for a while to see if it loads. Depending on content in the map and size of the map some content make take a while to load and appear frozen but it’s working in the background.

Thank you!


Oh, i think, the problem is another thing, not only 2 post process u run the bug project? directly in 4.12.2 and open NewSkyEffects2.umap.
apparently in log all open normally including outliner is updated.
we resolve re-creating level in 4.12, only leave register. thks

Thanks, for the project. I was able to narrow it down a little more and recreate this with 4.11.2 to 4.12 with the freeze.

I’ve submitted UE-31945 for this to be investigated.

Looks like all it took was having two Post Process Volumes with an ambient cubemap for each. No other settings needed to be adjusted in the PPV. If the camera was inside the PPV when the map loaded I would get the freeze. If the camera was outside of them (they were not set to unbound) I could load the map. As soon as I moved the camera inside the volume it would freeze.

Thanks for your help in reproducing this. :slight_smile: