"Get Attach Parent Actor" can't get attach parent actor

I want to create a wind that blows the actors in the volume.

I attached the blueprint named “Wind” to volume named “WindVolume”,
so I think “Wind” 's attach parent actor is “WindVolume”.



But when I call “Get Attach Parent Actor”, return None.

Can you tell me what’s wrong.

In this case WindVolume is the Attach Parent of Wind, and Wind is an Attached Actor. You need to use this node:


“Get Attached Actor” although empty…

I try to call both node with sandwiched between actors, but no signal.


So I probably don’t understand the phenomenon of “attach”.

Don’t rely on breakpoints too much. I’ve just tested it – it’s always "Current Value = "

Add a print string to see it right:

I solved it myself.

I had not call “Get Attach Parent Actor” at breakpoint.
Blueprint run along the Exec edge, so “Get Attach Parent Actor” is call when “For Each Loop” 's condition check node.


However, it is unknown why there is an item “Current value=” even though it is not executed, and it is “None”.

Thank you for your answer.
It solved, it seems that I had not understand much about blueprint & breakpoints.