Download

Geometry objects don't cast shadows

Hello there!

I have a problem with Unreal Engine 4.26.

When building geometry objects, they seem to have a side that is being lighted by the light source (movable) and a shadow side, but they don’t cast shadows.
I’ve made a screenshot with the problem. When building whole houses, the geometry doesn’t cast a shadow but meshes that I import into unreal engine do.

I hope you can help me! The light source is set to ‘movable’, but I also tried ‘static’ and ‘stationary’ and I haven’t found ANY solutions on google.

Have a good day!

No one knows something?

This will probably depend on the type of shadow the geometry is set to create. Static light sources produce static shadows (default), but dynamic (moveable) light sources require dynamic shadows. It is likely the geometry only has static shadows enabled, or has bCastShadow=false.

So if anyone else has the problem: the solution to my problem was Ray Tracing. The problem only occurs when Ray Tracing is enabled in my projects. As soon as you disable it, everything works fine!