Geometry flickering

I believe it is because of Z-fighting.

I’m not sure how to describe this problem because I’m new to Game Development and I don’t know the proper terms. Basically when I put my geometry flush with my Grid is starts to flicker like crazy. I’m following a course on Udemy. Here is a video I recorded:

This is a fresh install of Unreal Engine. Everything is set to their defaults.

Thanks to everyone in advance!

Welcome! I’ve always had this problem as well. Other forum posts tend to blame it on graphics card drivers but I’ve gone through 3 months of Nvidia drivers and they all have this issue. I have found two work-arounds for this:

  1. In the viewport, click the down-arrow in the top left and un-check ‘Realtime’ (alternatively press CTRL+R). Screenshot included below.
  2. Simply don’t build levels with surfaces flush at Z = 0. If you are using the grid as a visual aid, you can always switch to the top-down Ortho mode instead of Perspective or simply place your floor at Z = -5 cm or more beneath the grid. I recommend this option to avoid the flickering in all situations. I typically build at Z = 100 cm as my base.

Best of luck with your tutorials and future work! I believe the Realtime checkbox will control whether animations and
other visual effects will live-render in your viewport.

I’m also new to UE 4 and having the exact same problem!! Thank you so much!!

Wow awesome thank you so much!!!

I had the same problem, thanks!
I noticed that when I disable the anti-aliasing (under the “show” menu in the editor), the flickering no longer occurs, but just building levels at Z = 100cm and having anti-aliasing still enabled seems like a much better solution.

Hello PhidlerCrab

If your problem solved, can you “mark” this question as “resolved” to helping future UE4 users so they can find the solution if it occurs again.

Tahnk you.

Oh my bad! How do I do that?

The grid is rendered on the exact same plane. This will always cause z-fighting.
I kinda wish Unreal rendered the world grid at 0.00000001 to avoid this.

I was getting such a headache from the UI always flashing. You saved me. Thank you.