Geometry collection - material is replaced with world grid material

All my geometry collections has changed it’s material to the default world grid material. The material in their material slots is the correct one, but when I have the geometry collection in the level, it’s material is the world grid material. Is it a known bug? I have’nt seen a topic on this one.

1 Like

It’s like the uvs were so wrong, the material couldn’t be used on it. Did you find something ?

Edit : seems like it’s related to Nanite. If you disable it, the material works.
So I guess, 5.3 : no masked material support for nanite geometry collection.

select the material, and used the the detail pannel, in the usage, “used with Gemetry Collections”(checked)