Geometry Cache (Alembic) "Receives Decals" not working

Hi

I’ve been using the new geometry cache feature in UE4.13 and found that the standard rendering flag “Receives Decals” doesn’t seem to do anything at all for geometry cache components. I want to be able to turn decals off on my cache object but the flag is not working. The cache always receives decals no matter what that flag is set too.

Is this a known bug? Is there a workaround that we can use?

Cheers

Mike

Hi Mike,

There wasn’t anything reported that I could see in our system for Alembic having any issue with this flag. I checked in 4.13, 4.14, and 4.15 and all seemed to be working for me that I could see.

I have a simple .abc test asset. I drag in a default Decal Actor. I then select the test asset and in the Details panel I disable “Receives Decals” and I can see it toggle on/off for the test asset.

This is what I did to check. If you have any additional info or test asset that doesn’t respect this setting can you please share that? I’ve included my test asset that works when I checked this.

TestAsset

Thanks!

Tim

Hi Tim

I tried your example out and it does indeed work.

However I did a little more testing and it seems that the issue is specifically related to using a decal material which uses a DBuffer blend mode as shown in the image. We use the DBuffer to ensure our decals work with the baked lighting system, but this is causing our geometry cache to also receive the decal.

Any fix for this?

116068-decalblendmode.jpg

That did it! Good catch.

I’ve submitted a ticket for this that you can track the status of here: Unreal Engine Issues and Bug Tracker (UE-38993)

Unfortunately, I don’t have any workarounds for this issue. It is an experimental feature currently that is expected to have some issues like this. Hopefully it’ll be resolved in the near future.

Tim