GenerateProjectFiles.bat fails with odd compile errors

I’ve built from source a few times, but never encountered this error before. From a few Google searches, neither have many other people (zero ue4 related results).

This is from a fresh clone, after running setup.bat, then running GenerateProjectFiles.bat.

CSC : error CS1583: 'c:\ue4\Engine\Source\Programs\DotNETCommon\DotNETUtilities\obj\Development\CSC54A38D383FBB4FF490366DEE2166F686.TMP' is not a valid Win32 resource file [C:\ue4\Engine\Source\Programs\DotNETCommon\DotNETUtilities\DotNETUtilities.csproj]
CSC : error CS1583: 'c:\ue4\Engine\Source\Programs\EnvVarsToXML\EnvVarsToXML\obj\Development\CSCA9C77C57CBC44391AAB71CFEE69CF73B.TMP' is not a valid Win32 resource file [C:\ue4\Engine\Source\Programs\EnvVarsToXML\EnvVarsToXML\EnvVarsToXML.csproj]

Looking online, causes seem to range from invalid .ico files (doesn’t seem to apply to this case), mapped network drives (not using in this case), and not enough drive space (still have >1TB free on my C drive). I’ve been struggling with this one for two days now, I’ve tried the master branch and the 4.9 branch, same error on both.

Has anyone run into this problem before? Any ideas for fixes?

Hello Grimeh,

I have a few questions for you to gather some more information and try to cover all the bases.

  1. Have you successfully generated project files for 4.9 previously?
  2. Can you try downloading the source for a version you previously had no issues with to see if the problem persists there?
  3. What version of Visual Studio are you using and have you updated / added any extensions/add-ons recently?
  4. What version of windows are you using and have you upgraded recently?

Hi ,

  1. No I haven’t, the last I successfully compiled was 4.7 I believe.

  2. Problem still persists with 4.7 branch, which is the last I successfully compiled. I also tried 4.8, same issue.

  3. I have VS 2013 and VS 2015 RC installed, with Resharper C++ installed on my VS 2015 installation, and Visual Assist on my VS 2013 installation.

  4. I’m running Windows 10, the last version of UE4 I built successfully was with Windows 10.

Thank you for providing that information. I have a possible fix and something else I need as far as information goes if that doesn’t work. First, can you trying installing or reinstalling your Windows SDK? If that doesn’t fix the issue, can you download this file and run it? You’ll need to remove the .txt first as it needs to be run as a .bat (Answerhub won’t allow .bat files) and it should output an info.txt. This will give information about your Visual Studio 2013 install that could point out the problem. Could you attach that .txt in your next comment if the SDK doesn’t fix the issue?

I tried installing the Windows 10 SDK, but it fails with “windows installer service could not be accessed”, which I think might be indicative of something else but at this point I don’t have time to troubleshoot further. I suspect my development environment has been misconfigured somewhere along the line. I can’t even uninstall Visual Studio 2015.

I’ve attached the generated text file: link text

I’m going to have to just reinstall windows at this point, I’ve wasted too much time on it which we just cannot afford. Let me know if there’s any other diagnostics you’d like me to run before I wipe it.

Hello Grimeh,

Can you try compiling a basic C++ project with Visual Studio and see what happens in that case? When I say basic, I mean without the engine, just a simple Hello World or something or the sort. If you are unable to do so, you may need to contact Microsoft with this issue as the problem may be with Visual Studio instead of UE4 itself.

We haven’t heard from you in a while, Grimeh. Are you still experiencing this issue? If so, please let me know with a comment and the issue will reopen. In the meantime, I’ll be marking this issue as resolved for tracking purposes.