GenerateProjectFiles.bat Error

So I recently downloaded Ue4 Source code from Github. I ran the Setup.bat, but when I run the GenerateProjectFiles.bat I get this error:

We couldn’t find a valid installation of Visual Studio. This program requires Visual Studio 2015. Please check that you have Visual Studio installed, then verify that the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\14.0\InstallDir (or HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\14.0\InstallDir on 32-bit machines) registry value is set. Visual Studio configures this value when it is installed, and this program expects it to be set to the ‘\Common7\IDE’ sub-folder under a valid Visual Studio installation directory.

So as instructed I went to regedit to verify the Hkey values in InstallDir… however I can’t locate that value in the path provided in any of the versions. All that I see is :

Fearing I might’ve messed up something in the installation process, I have “Repair” VS in the installer 3 Times, and Unistalled VS2017 about 3 times as well and re-installed it but there still isn’t any value named as such. I do understand some of the registry info of VS is now located differently from older versions. But I’m not sure if this is a VS issue and how to fix it or if its a Path issue in the environment variables but I’ve made sure that there is only one C:\Windows\System32; in the system variables… I’ve also deleted the git Source code and downloaded a Zip and tried it that way to see if it had any effect but nothing seems to work.

I currently use VS Community 2017. I have no other VS versions.

I quit… I just Uninstalled for the 5th time, after Reseting my PC and I still have the same problem… it appears after Version 15.2 of VS2017 it no longers creates the registry data as it once did before. So I’m guessing its no longer an issue of my computer or the way I am installing but rather an issue with the compatibility between both ue4 and newer versions of VS.

Anyway if someone else runs into the problem let me know if you have an update on a solutions. So far I’ll just either wait or just download previous versions of VS.

Good luck!