General Blueprint Crash

Hi
I just deleted 4.9.2 and installed 4.10. I am complete new to UE4 so I was following a blueprint tutorial. Then I realized I cannot create any blueprint. I right clicked in content browser, click “Blueprint Class”, and then it stuck forever that I had to close the whole engine via task manager. I could see there is another window at the bottom of the screen which affiliated to UE4 window, named “Pick Parent Class”. It just never showed up. In the task manager the engine didn’t respond.
It would be fatal if I cannot use blueprint. Do you have any idea or experience on this one? Should I delete the whole engine and re-download it or there is a fix or a patch?
Thanks!

I suggest you to verify your current version. Open Epic launcher, go to library, there should be a list of installed version on the right side, next to Launch button there should be a drop down list, choose Verify and wait for the launcher to perform its magic. After that, try again. Also, you really shouldn’t deleted 4.9.2 this soon. 4.9.2 still got a bunch of bug, but at least it is kinda stable, while 4.10 will need further work on it. I won’t say you should delete 4.10, unless you need to free some space for 4.9.2, but at the moment, i won’t put 100% of my effort to develop a project on 4.10, at least until they have release 1 or 2 quick patch.

Thanks for reply. But I have tried verifying. I even re-downloaded the whole 4.10. It still didn’t work.

Sometime you got bad luck like that, have tried to convert my project form version 4.6 to version 4.7 and 4.8, that project got 90% blueprint and 10% code C++, the result was pretty banana, migrate one part of the project also impossible, due to the fact that UE can’t migrate C++ code and those code sink deep into blueprint code. In the end, i have to re-do my project from scratch on the new version, but at least i got a legit chance to re-structure my code, and got a better understand of my project.

So you got several choices here, either re-do your project on new version from scratch, which is pretty bad, but not entirely a bad ideal. Other choice is that you continue to work on the lasted stable version, which is version 4.9.2. Third choice is that you spend time to re-structure your blueprint code into separate modules, and migrate them from your old project 4.9 to a blank new project 4.10, which is not a bad choice, but i am not sure about whether it will work or not.

I also strongly suggest you to look around the forum and answer hub for similar case and their solutions. Good luck and stay strong mate.

Hi Freeman|TR,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What was the most recent addition to your project before this started occurring?
  • If you remove your contents from your contents filepath and open the project do you still see the freezing occur?
  • Can you post a copy of your dxdiag here so I can take a look?
  • Do you have VS 2015 installed on your pc?
  • Can you post your crash logs (\Unreal Projects\PROJECTNAME\saved\logs) and your crash callstack here so I can take a look?

I understand game engine is complicated and there will be bug. I’m trying to contact epic support now since there is no similar general blueprint freeze like this one. Thanks for your detailed explanation!

Thanks for reply! This is a general crash that occurs anywhere in my engine. I’m a starter so my project is completely blank and created from scratch. I tried to create project without starter content but it still happens. I also got VS 2015 Community (after installing UE4) but it doesn’t help.
My crash log is attached.link text

dxdiag
link text

lol At least I learned something new about dxdiag ha.

The first thing to check is make sure that your computer is definitely using your Nvidia graphics card, not the Intel Integrated card. The integrated HD card is not well suited for the editor and will absolutely crash if it is being used instead of the nvidia card.

I realized that I was always using intel card to run ue4. I’m not sure if it is the correct way to revise it to NVIDIA. I clicked the NVIDIA setting in my system tray. I added both epic game launcher and unreal engine 4 in my program settings and configure them both to use NVIDIA card. I even set the primary card to NVIDIA in global settings. As I launched engine again I still find the same problem.

What are the exact steps you are taking before the crash occurs? Are you able to actually open the editor or does it crash before the editor fully opens?

Since I’m a starter, all I do is to create a blank project with NO starter content so there is basically nothing in the project. And then I try to right-click in the content browser and left-click the blueprint class to create it. Then it freezes.

Also I try to shut down norton firewall and protection but doesn’t help.

Plus, now the engine is run with NVIDIA since I see UE4’s icon in a indicator showing application run by NVIDIA.

One more thing worth noting. It occurs in 4.9.2 too. This might be a fatal problem the dev team want to fix quick.

Are you still there? Is this problem solvable?

Hi Freeman|TR,

In general we do not have support team members available on weekends. We ask that you give us up to four days to adequately check into and respond back to an answerhub post. If you have not heard anything within 4 days, feel free to bump the thread once.

Unfortunately, I have not been able to reproduce this on my end as of yet. Try opening the project directly from the project file. To do so, go to \Unreal Projects\PROJECTNAME\ and double click the .uproject file that is located within this folder. Additionally, instead of using RMB to create a blueprint, try pressing the “new” button at the top of the content browser, does the freeze still occur? How long are you leaving the project open before closing it down as completely frozen?

Check your task manager, how much of your GPU/CPU is being consumed when the editor freezes? Do you see it jump or does it remain the same? Are you able to do anything outside of the editor while this freeze occurs?

Hi Adam, I opened it directly from .uproject but still froze. The CPU remains around 35% before freeze, but it drops immediately to around 9% after the freeze occurs. The RAM remains around 30%. Both methods creating the blueprint lead to freeze. I waited for 15 minutes and it was still freezing.

How much space do you have on your harddrive? We’ve seen a few instances where not having enough space on your harddrive will cause freezing to occur. Try clearing out some space and see if that addresses the error.

Currently it’s 18.5 GB left of all the 118 GB on my SSD. Is that enough space? What’s the recommended space? Is SSD a problem?