[GearVR] Changing IPD via STEREO E=val doesn't work


I’m trying to tweak IPD in my application on runtime. I’ve found out that the easiest way would probably to invoke STEREO E=0.007 command.

Unfortunately, it seems that this is ignored on GearVR because there’s no effect.

On the other hand, STEREO CS=1.1 seems to be working, but it isn’t suitable for my needs.

Also, from what I could read from GearVR.cpp, it should be possible to override IPD settings via the following lines in DefaultEngine.ini:


This doesn’t seem to work either.

It all boils down to the fact, that rendering via GearVR seems to ignore whatever is set via FHeadMountedDisplay::SetInterpupillaryDistance

Hi MiKom,

I’ve submitted a ticket for this which you can track here: Unreal Engine Issues and Bug Tracker (UE-38516)



I can’t believe this feature still not solved!!!