[GearVR] Back Button behavior no longer as expected in 4.11 P6

There has been a change in 4.11 Preview 6 where the back button goes instantly to the “Oculus do you want to quit?” screen. The functionality should be like it was previously where the back button can be controlled by us and we call this screen via the console command when we are ready to send the user there.

To reproduce:

  • use the “Android Back” node to do something
  • package the project and run on the gearvr
  • press the back button

Notice you are sent straight to the do you want to exit oculus menu screen instead of your UE4 logic.

Hi Aussieburger,

I’m not seeing the same issue on my end with the GearVR.

When I tested this between 4.10 and 4.11p6 I’m seeing the same behavior when assigning the Android Back button event to do something. I have a simple cube in the scene and toggle its visibility using the back button from the android device.

If you put the phone in Developer Mode so that you don’t need the GearVR headset plugged in to test the project, do you see the same when you press the back button on the android phone?

Let me know.


Hi Tim,

I have no problem reproducing it via dev mode as well. Also I created a new totally blank project and have the same problem - are you sure you were testing with 4.11 P6? As mentioned all previous UE versions and Previews worked as expected:
link text

edit: ignore that savegame stuff I was also testing in there :wink:

I have the same issue. 4.11p6 shows the oculus menu instantly.

I was able to get this. Not sure what I did the first time around that didn’t reproduce the issue, but getting it to occur now. I’ve entered UE-27992 for this to be tracked.


Hi aussieburger -

Going to the Oculus home screen is the new default behavior and can be disabled using the the CVar “gearvr.HandleBackButton”. Once this new default behavior is disabled the button bindings should work as expected.

Let us know if you experience differing behavior.

Eric Ketchum

Hi Eric, how excatly do we use the CVar you mentioned? Console command?


This can be set in BPs by using an Execute Console Command node, using the Tilde key and entering the command, and/or by setting it in the ConsoleVariables.ini file located in the Engine folder.

Hi Tim & Eric,

It doesn’t appear to be working for me - (set via Execute Console Command node). Do I need to set it to either =0 or =1 ? I’m just putting it in as:

Is there a list of other gearvr related CVars somewhere?? That would be awesome

I currently don’t have access to the GearVR, but another one of team has one that I’m having them run with a test project. Oddly, I don’t see the CVar listed when I use DumpAllConsoleCommands, but that doesn’t mean it’s not there. There are some that are not listed. Once I hear back from him I should have a more definite answer for you, but typically you should be able to enter just “gearvr.HandleBackButton X”, where X represents a value of 0 or 1 to enable or disable. The only time you should need the = would be in an .ini file.

I’ll update you as soon as I hear back from my colleague.

Ok, so using the CVar gearvr.handlebackbutton 0 will allow you to have the old functionality and use the Android Back Button node without going to the Oculus Home screen.

Is anyone having issues with the progress bar when back button is held down. it was working fine in UE4.10 after opening the project in UE4.13 the bar is weirdly separated and looks too 3d…

is this still the case?

just tried execute console command (CVar gearvr.handlebackbutton 0) in my level blueprint on event begin play after a 1 second delay and oculus home still comes up.


using UE4.13.1


Functionality appears to be the same between 4.13.1 and my internal build of 4.15 using this command.

You can test this like I did by having the execute console command for GearVR.HandleBackButton 0 on EventBeginPlay and then have an AndroidBack Button node when pressed triggers a movable actor to simulate physics. In my test, it never goes back to the Oculus Home Screen.

Testing this with and without the Delay before executing the console command worked in my case.


Sorry, I didn’t catch earlier when you use the parenthesis that you were actually using “CVar” in the command.

You only need to have it as the following to work:

gearvr.HandleBackButton 0

CVar was just my shorthand for console variable. :slight_smile:

thanks for the response.

edit: do i need to put CVar in the node?

maybe the command is different?
i’m using 4.13.1 git source.

here is an image of my level blueprint.

and here is what i get in my gearvr log

11-03 13:46:11.431 27019 27032 D UE4     : [2016.11.03-20.46.11:439][  0]Command not recognized: CVar gearvr.handlebackbutton 0

11-03 13:46:11.431 27019 27032 D UE4     : [2016.11.03-20.46.11:440][  0]LogBlueprintUserMessages: [gearMap_C_0] COMMAND EXECUTED

yeah i didn’t think to remove CVar until i saw the image posted.
then i figured that was my issue.
thank you.