[GearVR] Application doesn't recover from stand-by mode.

We are developing an application for GearVR on Android using UnrealEngine 4.17.
We have encountered a problem with our application not being able to recover from stand-by mode.
The problem only happens on Samsung S7 US (Snapdragon) version with android 7.0. Everything works ok on Samsung S7 EU version and S8 cellphones.

The steps basically are:

  1. Run application using GearVR

  2. Take headset off

  3. Wait ~10 seconds for application to being paused

  4. Put headset on.

  5. Observe infinite black screen, no app present.

I was able to check some logs from both cellphones EU/US with adb logcat, and note down some of the lines I found important.

What is worth to mention is that on EU version we have a correct behavior like this:

Link to: Text Log of EU/US Cell phone comparison

As we can compare, on US version we didn’t receive any resume events, instead, we got some events about app window being destroyed.

According to Lifecycle The activity lifecycle  |  Android Developers the app was destroyed.

I have checked other random application on Oculus store, have the same issue, but the app was made in Unity.

Found this post which has same issue, but it’s not the case for me: Solved: [SOLVED] Taking gearvr off head hangs application ... - Meta Community Forums - 638495

Does any one of your fellow developers have had such problem before?

Am I missing something that I should find in my logs?

Where should I search for solution?

Is this issue fixable from our app/engine or it is beyond our scope?

Thanks in advance for any response.

Edit: We already did some testing, we have bunch of cellphones, but all of them are Samsung galaxy. The issue seems to only happen on Snapdragon chipset.

We used Third person UE4 template on clean 4.17, with Samsung S7 US, Android 7.0. Sadly, the issue is still present. In the attachment you can find a logcat log file from the session, it is filtered with UE4 only for clarity. I have marked action moments by ## in the log.

I already reached out to Oculus about this so they might assist in solving this issue.

Link to project: Us-on-clean-4.17

It sounds like you’re doing the right thing. Given the nature of the issue, talking with Oculus is what we recommend. They have better insight into what is going wrong here (especially since it also happens with apps that weren’t built using Unreal).

Please let us know what they say! I’d like to have that information to pass along to any others that experience the same issue. And if they come up with a fix I am sure it’ll be passed along to us.

In the meantime, a report has been written and logged in our Jira. Please feel free to use the link provided to track any future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-51326)