Download

GearVR app rejected ?!!

Hi all,

I developed an app for GearVR. Everything i had tested ran fine on my end. Now i have received the following message from the Oculus team. Does someone know hoe to go about it??

I have no idea on how to reproduce the same. Can it be because my osig file is still within the app??

I don’t know how it works with UE4, but apps/games built with Unity do that automatically. If you launch Gear VR app, it will ask you to plug your phone into Gear VR. Once you do so, the app launches in VR mode.

Hi kinzua01,

Did you try the validation tool on your APK?

https://developer.oculus.com/validator/

This may help track down the issue. Also, a number of improvements to pass validation are in 4.10 (manifest changes, entitlements checking, removing osig from distribution builds).

Note if you get a warning about the OpenGL version you can ignore it; they have a bug in their parser for getting this property from the latest build tools version of aapt.

Hey Chris,

I did the whole submission validator thing and got through with one warning.
The warning is for an osig file present in the package. And that’s all.
I had gone through the Oculus submission guidelines.
There was a mention in the guidelines, that if any osig is present, it’ll be removed once the app reaches them.
Before submitting the app i had thoroughly checked it on my phone and it ran completely fine.
I even made sure that i did adhere to every possible guideline.

If anyone from the team wants to take a look, i am more than willing to share my project files.

Which version of the engine are you using and did you test your ‘for distribution’ export? ‘For distribution’ did not work for me in 4.9 so I had to do a lot of workarounds to get a version that passed the oculus validator

I published the build with 4.9.2
Here’s what i did.
I packaged the project with ‘Shipping’ configuration.
Then i checked it on my phone and it ran fine.
Then i ran it on submission validator and got errors.
Following this i took these steps ::

  1. Check marked ‘For Distribution’
  2. Configured the AndroidOverrideManifest.
  3. Ran it again on the validator.
  4. Got One warning for the osig being present.
  5. Uploaded on the Oculus submission page, got no errors.
  6. And then finally, i heard from Oculus, the message, i hadn’t dreamt of.

I hadn’t tried the submission build on my phone. I’ll try and run that though.
Still what steps should one take beyond the ones i specified above??

Yeah ‘For Distribution’ does not work with 4.9.2 - it seems to be stripping important gearvr related stuff.

PS: you can test your build without the launcher by using this free app: https://play.google.com/store/apps/details?id=com.sika524.android.quickshortcut&hl=en and then you would see you get the same problem as oculus :wink:

The only way to submit with 4.9.2 was to do the following:

  • Do all the manifest override stuff
  • export with shipping and ‘for distribution’ **unchecked
    *** unsign the app (Open the apk as a zip file and remove the META-INF directory - then rename back to apk)
  • manually sign with your keystore
  • manually zipalign

test with the shortcut app above then the oculus validator

That works but much easier now is to just use 4.10 :wink:

Thanks aussieburger,

Will take a shot at the steps you mentioned above. Or just move over to 4.10 . :wink: