Download

[GEAR VR] "Set CPU and GPU levels" doesn't seem to work.

I have the said node connected to Event Begin Play in the Level Blueprint, both CPU and GPU set to 1, yet the OVR metrics tool when running the game reports CPU: 2, GPU: 3.
Am I doing something wrong?

EDIT: Using 4.17

Finally sorted this out.

I had a UI widget which i used to draw the crosshair/target for the GVR controller. For whatever reason it was interfering with the explicitly set CPU/GPU levels and was having quite a huge impact on performance. Replacing that with a quad Stereo Layer solved both the problems.

Ok, so after a while, it still seems like the said node isn’t working properly.
After a while, without any significant modifications to the scene, the OVR Metrics overlay shows CPU2/GPU3, despite the fact that in the level Blueprint it’s set to 2/2.
Any insight would be appreciated!

You could try setting it in the DefaultEngine.ini file in your projects config folder:

[GearVR.Settings]
CpuLevel=2
GpuLevel=2

I use that rather than the BP node

Thanks, I was looking for these specific entries. Though I’ve seen them somewhere.
Found out that If i tie the BP node to ticks (stupid, I know), it works, but something is preventing it from working properly when connected to BeginPlay in the level blueprint. Weird enough, the description for the node isn’t the correct one, too.

Unfortunately adding this to the DefaultEngine.ini isn’t helping either. May have something to do with the refactoring of the Oculus plugin.