Gear VR Hitting 60 FPS Tips

So I’m trying to get an extremely simple screen to run at 60 FPS on the gear vr and everytime I look at the floor it drops to around 40-50. Could someone please point me in the right direction to fix this? The scene is the blank default with no added objects. Literally the floor and skybox.

What I’ve done so far:

  • Created a blank project on Mobile settings.
  • Changed all lighting to static
  • Changed settings to get the project to run on gear (change android version, manifest, disabled touch input)

Tried remove this skybox with no luck. But I’ll have a look at that project, just waiting for permission on Google Drive :slight_smile:

I played around with the material on the default floor, specifically changing the settings which are the “cheapest” from the best practice guide. I was able to hit 60 FPS consistently! Thanks for the advise.

But what if I need skies ?

Create a simpler material sky - the one with the default assets is very “high end” and too much for mobile