[Gear vr] first frame shown non-stereo UE4.9

To reproduce:

  • Use the attached project
  • Add you OSIG file in Build → Android → java → assets
  • Export as Android → ETC2

Notice when you start the app → insert into the Gearvr when prompted then put on the gear for a split second you see the scene not in stereo then the screen goes black and a split second later it returns as expected (stereo).

Occurs all the time on every UE4.9 project on my Note 4 Exynos chipset device.

[simple example project][1]
[1]: 60517-gearvr49test2.rar (948 KB)

I have the same issue with any project I build (from scratch) since the 4.9 UE4 version.

Hi AussieBurger,

I was able to reproduce this in 4.9 and our latest 4.11 branch. I was able to verify that this was not the case with 4.8 and have submitted UE-21714 for this to be investigated. There is no ETA on when this will be addressed, but I will post back here once I have any updates to pass along.

Thank you!



We try some workaround:
A solution for us was to set “enable HMD” on begin of our player.
It seems that it’s correct this first frames glitchs.