Download

GEAR VR: Deferred Decals not showing

Hi all,

I am trying to build a very simple scene (square room with a few slides as decals on the walls) for Gear VR.
Everything works fine, except I can’t get the Decals to show when i view my project on the Gear Itself. The decals pose no problem in the viewport

I am on the lastest UE4 build 4.19.2
I created a completely empty project (no engine content, mobile, scalable) and just added a wall with a basic (base color only) material
My decal material is a just a simple picture and has no problem rendering in the viewport
I am building for a Gear VR on a Samsung S6 edge +
The packaging runs fine and gives no errors or warnings

I have tried all combinations for:

  • packaging settings i tried them all, but stick to multi now assuming this will cover all possibilities
  • forward shadowing in project settings
  • DBuffer and Zpass settings in project settings and the corresponding settings in the decal-material

I have been on this for a week trying to find a solution. Looking at the google results so far i get the feeling this is not a widespread problem, so it must be something very specific and/or obscure :slight_smile:

Does anyone have any idea’s what i might be doing wrong?

Best regards,

Jasper

The thing is decals require Mobile HDR, which doesn’t get along with VR.

I wonder how to make simple decals that work on mobile VR and don’t bog down performance

Thanks for your reply.

Yesterday I figured out the HDR setting.

When i use HDR and turn OFF the forward shadowing and turn OFF the DBuffer & Zpass (also adjust the Decal-material for this) and use ES2 and NOT ES3.1 then i get to see my decals in the GearVR.

  • The only thing is now that the Decals look almost emissive , even with almost no lighting in the scene the Decals look very bright. Maybe i should try out unlit in the Decal-material setting ??
  • I also don’t understand why with the ES3.1 the decals are showing in the mobile preview, but not in the GearVR,

Hopefull