Gear VR builds go straight to Oculus Home 4.9

Hi guys!
I can’t get any UE4 4.9.2 build run on S6 Gear VR. Last time I checked, it was 4.7 and it worked, but was pretty ugly with no anti-aliasing whatsoever. I saw this video Gear VR UE4 49Pr MSAATest - YouTube and decided to give it a go once more :slight_smile:

I think I followed all the manuals and tutorials :confused:

  1. I’m making an empty C++ project
  2. Un-checking Oculus Rift Plugin
  3. Setting proper Android and Android SDK
  • click the ‘Configure Now’ button for Android support
  • Set the Minimum SDK version to 19
  • Check the ‘Configure the AndroidManifest for deployment to GearVR’
  1. Copy OSIG file to Engine/Build/Android/Java/assets/
  2. Build
  3. Package’File/Package Project/Android/Android (ETC2)’

And after running the app and connecting Gear VR the app goes straight to Oculus Home :confused:

Has something in the process changed or am I still missing something?

Hi John,

Using one of my recent test Gear VR projects using the FirstPerson template I’m not seeing this on my end.

I’ve got a Galaxy Note 4 that I’ve tested on. You’re settings above seem to be correct.

Can you try launching to the device without packaging and see if that works for you.

You can do this by having your Samsung plugged and in the main toolbar selecting the drop down arrow next to the Launch button. You can then select the Samsung device that is hooked up. It will take a few minutes to launch directly on the device, but see if this method works. If so, maybe we can work from there to see why it’s not packaging correctly and loading like I’m seeing on my current device. We do have a S6 that I can test on as well, but I want to verify this part before checking it out from our inventory.



I’m having the exact same problem. Tried launching straight to the device. Also crashes. I’ll update my UDN ticket.

Also experiencing this issue with UE4 4.9.2 build run on S6 Gear VR, both with launching straight to the device and Build/Package on Android (ETC2). Opening app and launching just takes me straight to Oculus Home.

Edit: I can confirm same issue with both build and straight launch for UE4 4.7.6 and 4.8.3

Hi Tim,
I tried your way and it was exactly the same - a brief moment of black screen an then directly to Oculus Home app.

I think I’ve narrowed it down to the FMOD plugin I was using. But no one has been able to reproduce the crashing. What OS and SDK version is everyone using?

I actually got it working with the Galaxy 6S Android 5.1.1 on UE 4.9.2 C++ thanks to this thread :

I also set my build configuration to debug mode for what it’s worth.